summaryrefslogtreecommitdiff
path: root/package/lksctp-tools
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-03-02 18:07:51 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-02 23:21:03 +0100
commit574a2886ad3af6c14e56914b82cf29ca5828be8e (patch)
treec079f584ed48454284bfab7f716f819af40c45ec /package/lksctp-tools
parentdb6b5ad9bb7756420950edd0b0fb28ed1cdc0057 (diff)
lksctp-tools: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lksctp-tools')
-rw-r--r--package/lksctp-tools/Config.in16
-rw-r--r--package/lksctp-tools/lksctp-tools.hash3
-rw-r--r--package/lksctp-tools/lksctp-tools.mk27
3 files changed, 46 insertions, 0 deletions
diff --git a/package/lksctp-tools/Config.in b/package/lksctp-tools/Config.in
new file mode 100644
index 000000000..b8a8c7af9
--- /dev/null
+++ b/package/lksctp-tools/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_LKSCTP_TOOLS
+ bool "lksctp-tools"
+ depends on BR2_USE_MMU # fork()
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ The lksctp-tools project provides a Linux user space library
+ for SCTP (libsctp) including C language header files
+ (netinet/sctp.h) for accessing SCTP specific application
+ programming interfaces not provided by the standard sockets,
+ and also some helper utilities around SCTP.
+
+ http://lksctp.sourceforge.net/
+
+comment "lksctp-tools needs a toolchain w/ threads"
+ depends on BR2_USE_MMU
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lksctp-tools/lksctp-tools.hash b/package/lksctp-tools/lksctp-tools.hash
new file mode 100644
index 000000000..ae6b0dc3f
--- /dev/null
+++ b/package/lksctp-tools/lksctp-tools.hash
@@ -0,0 +1,3 @@
+# From https://sourceforge.net/projects/lksctp/files/lksctp-tools/
+md5 708bb0b5a6806ad6e8d13c55b067518e lksctp-tools-1.0.16.tar.gz
+sha1 8b17f913844851ee6872374cffec0745c804637b lksctp-tools-1.0.16.tar.gz
diff --git a/package/lksctp-tools/lksctp-tools.mk b/package/lksctp-tools/lksctp-tools.mk
new file mode 100644
index 000000000..91b96a63c
--- /dev/null
+++ b/package/lksctp-tools/lksctp-tools.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# lksctp-tools
+#
+################################################################################
+
+LKSCTP_TOOLS_VERSION = 1.0.16
+LKSCTP_TOOLS_SITE = http://downloads.sourceforge.net/project/lksctp/lksctp-tools
+LKSCTP_TOOLS_INSTALL_STAGING = YES
+# configure not shipped
+LKSCTP_TOOLS_AUTORECONF = YES
+LKSCTP_TOOLS_LICENSE = LGPLv2.1 (library), GPLv2+ (programs)
+LKSCTP_TOOLS_LICENSE_FILES = COPYING.lib COPYING
+
+# Needed by autoreconf
+define LKSCTP_TOOLS_MAKE_M4
+ mkdir -p $(@D)/m4
+endef
+LKSCTP_TOOLS_POST_PATCH_HOOKS += LKSCTP_TOOLS_MAKE_M4
+
+# Cleanup installed target source code
+define LKSCTP_TOOLS_CLEANUP_TARGET
+ rm -rf $(TARGET_DIR)/usr/share/lksctp-tools
+endef
+LKSCTP_TOOLS_POST_INSTALL_TARGET_HOOKS += LKSCTP_TOOLS_CLEANUP_TARGET
+
+$(eval $(autotools-package))