summaryrefslogtreecommitdiff
path: root/package/lockdev
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-22 21:39:17 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-22 21:39:17 +0100
commitc61e97a4d9779e72004e563d00e7985104cba462 (patch)
treef54307364b90dea7f1d11059bf8772e146f343a8 /package/lockdev
parent2badd96d9e933afc052f78c1a91cdc5dd98e1a1f (diff)
lockdev: fix build with the musl C library
When the musl C library is used, the __GNU_LIBRARY__ symbol is not defined, so the lockdev code doesn't know what to do. To work around this, we explicitly pass __GNU_LIBRARY__ when building with musl, this musl provides what's needed for lockdev to build, as if we were building against glibc. Fixes: http://autobuild.buildroot.org/results/9db/9db4ab40955d3af0027e141245d73ee6c614fb1f/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lockdev')
-rw-r--r--package/lockdev/lockdev.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/lockdev/lockdev.mk b/package/lockdev/lockdev.mk
index e40a407d3..a45e22e73 100644
--- a/package/lockdev/lockdev.mk
+++ b/package/lockdev/lockdev.mk
@@ -24,6 +24,12 @@ LOCKDEV_BUILD_ARGS = shared
LOCKDEV_INSTALL_ARGS = install_run
endif
+# Make the code believe we are using a C library compatible with
+# glibc, which for the purpose of lockdev is actually true.
+ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
+LOCKDEV_BUILD_ARGS += CFLAGS="$(TARGET_CFLAGS) -D__GNU_LIBRARY__"
+endif
+
ifeq ($(BR2_SHARED_STATIC_LIBS)$(BR2_SHARED_LIBS),y)
define LOCKDEV_CREATE_LINKS_STAGING
ln -sf liblockdev.$(LOCKDEV_VERSION).so $(STAGING_DIR)/usr/lib/liblockdev.so