summaryrefslogtreecommitdiff
path: root/package/lttng-libust
diff options
context:
space:
mode:
authorPhilippe Proulx <eeppeliteloop@gmail.com>2016-10-31 03:46:17 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-01 15:05:58 +0100
commit15ce62bbf33f1527b5553695d4641fba134dcd6c (patch)
tree5d2c1d7962927b7e5a521723c05d18c245ddf5d5 /package/lttng-libust
parent006c7ab5c45e3fc42729dbe242a0418fb8133c82 (diff)
lttng-libust: enable Python agent when Python is available
Add the --enable-python-agent configure option to build the LTTng-UST Python agent when Python 2 or Python 3 is also part of the BR image. The LTTng-UST Python agent is a Python package which adds LTTng tracing to Python's standard logging when imported. Disable the Python agent otherwise. Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lttng-libust')
-rw-r--r--package/lttng-libust/lttng-libust.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/lttng-libust/lttng-libust.mk b/package/lttng-libust/lttng-libust.mk
index feeeb4325..7a83f4642 100644
--- a/package/lttng-libust/lttng-libust.mk
+++ b/package/lttng-libust/lttng-libust.mk
@@ -15,10 +15,13 @@ LTTNG_LIBUST_CONF_OPTS += --disable-man-pages
ifeq ($(BR2_PACKAGE_PYTHON),y)
LTTNG_LIBUST_DEPENDENCIES += python
+LTTNG_LIBUST_CONF_OPTS += --enable-python-agent
else ifeq ($(BR2_PACKAGE_PYTHON3),y)
LTTNG_LIBUST_DEPENDENCIES += python3
+LTTNG_LIBUST_CONF_OPTS += --enable-python-agent
else
LTTNG_LIBUST_CONF_ENV = am_cv_pathless_PYTHON="none"
+LTTNG_LIBUST_CONF_OPTS += --disable-python-agent
endif
$(eval $(autotools-package))