summaryrefslogtreecommitdiff
path: root/package/lua
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-04-05 17:21:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-05 19:20:56 +0200
commitc97aeb7e84d5d34e2833f6f143b061b856acf7e1 (patch)
tree5adb4efe4314d23a4d75703eb78ea94eb33495a7 /package/lua
parent50dfaef6ec2d1bcfb6db232a3802882d3054707c (diff)
package/lua: rename config options
Package's options should be named after the package. Lua is an interpreter, but the package is named 'lua'. So we want to name the config option with '_LUA_', not with '_LUA_INTERPRETER_' Besides, naming them with '_LUA_INTERPRETER_' might be confusing, since there is a package named 'luainterpreter'. Since the renamed options are part of a choice, we can't use the legacy options to select the new ones. So we instead instruct the user to go select the appropriate option in the choice. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Francois Perrad <fperrad@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/Config.in10
-rw-r--r--package/lua/lua.mk4
2 files changed, 7 insertions, 7 deletions
diff --git a/package/lua/Config.in b/package/lua/Config.in
index 2f1b25bef..0e318585c 100644
--- a/package/lua/Config.in
+++ b/package/lua/Config.in
@@ -30,22 +30,22 @@ config BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION
default "5.2" if BR2_PACKAGE_LUA_5_2
choice
- prompt "Lua Interpreter command-line editing"
- default BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
+ prompt "Lua command-line editing"
+ default BR2_PACKAGE_LUA_EDITING_NONE
-config BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
+config BR2_PACKAGE_LUA_EDITING_NONE
bool "none"
help
None.
-config BR2_PACKAGE_LUA_INTERPRETER_READLINE
+config BR2_PACKAGE_LUA_READLINE
bool "readline support"
select BR2_PACKAGE_READLINE
select BR2_PACKAGE_NCURSES
help
Enables command-line editing in the Lua interpreter.
-config BR2_PACKAGE_LUA_INTERPRETER_LINENOISE
+config BR2_PACKAGE_LUA_LINENOISE
bool "linenoise support"
select BR2_PACKAGE_LINENOISE
help
diff --git a/package/lua/lua.mk b/package/lua/lua.mk
index bf68e654f..bc8799a08 100644
--- a/package/lua/lua.mk
+++ b/package/lua/lua.mk
@@ -31,12 +31,12 @@ else
LUA_MYLIBS += -ldl
endif
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_READLINE),y)
+ifeq ($(BR2_PACKAGE_LUA_READLINE),y)
LUA_DEPENDENCIES = readline ncurses
LUA_MYLIBS += -lreadline -lhistory -lncurses
LUA_CFLAGS += -DLUA_USE_READLINE
else
-ifeq ($(BR2_PACKAGE_LUA_INTERPRETER_LINENOISE),y)
+ifeq ($(BR2_PACKAGE_LUA_LINENOISE),y)
LUA_DEPENDENCIES = linenoise
LUA_MYLIBS += -llinenoise
LUA_CFLAGS += -DLUA_USE_LINENOISE