summaryrefslogtreecommitdiff
path: root/package/luajit
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2015-07-17 14:46:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-18 21:06:02 +0200
commitb2e8f28efac7125a6a8cf1db9087b3710101b487 (patch)
tree95795f3112ade220a1ace3dee35b7c16385e1772 /package/luajit
parent6c7d490558498888a783fe3ca53f1a3b6cef1b16 (diff)
package/luajit: disable for static build
luajit requires dlopen(). Fixes: http://autobuild.buildroot.net/results/20d/20dfb10198f3688f92208591960192ca08280987/ http://autobuild.buildroot.net/results/c3c/c3cfdf8dfb315bf64caa9ed0f362016111fd93ac/ http://autobuild.buildroot.net/results/8cb/8cbf6207ecf7b254aeccd9ec5c07376a044e1f8f/ [Thomas: propagate the new dependency to the sysdig package, which selects luajit.] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/luajit')
-rw-r--r--package/luajit/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/luajit/Config.in b/package/luajit/Config.in
index f6995e22f..8ce528b2c 100644
--- a/package/luajit/Config.in
+++ b/package/luajit/Config.in
@@ -8,6 +8,7 @@ config BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
config BR2_PACKAGE_LUAJIT
bool "luajit"
select BR2_PACKAGE_HAS_LUAINTERPRETER
+ depends on !BR2_STATIC_LIBS # dlopen
# Luajit is only available for some target architectures, and
# has some complexity wrt 32/64. See luajit.mk for details.
depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
@@ -32,3 +33,6 @@ config BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION
default "5.1"
endif
+
+comment "luajit needs a toolchain w/ dynamic library"
+ depends on BR2_STATIC_LIBS