summaryrefslogtreecommitdiff
path: root/package/luarocks
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-06-22 21:07:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-05 15:53:05 +0200
commit50adab522c0fbf1c99b904b8513200b114eb4a0b (patch)
tree5ff32934efcc96e15eedc81ceabdf94488def225 /package/luarocks
parent624dbec7e1f971519be9a165b09c0b95a8ee282b (diff)
packages: use the <PKG>_TARGET_FINALIZE_HOOKS
Register package-specific target-finalize hooks with the newly-introduced <PKG>_TARGET_FINALIZE_HOOKS. This incidentally fixes luarocks, which was registering target-finalize hooks even when it was not enabled. To be noted, the skeleton package is not converted, because it is not optional, we always have it; so its hooks would always be registered anyway. Besides, the followup patches would render this conversion moot anyway, since those hooks would be spread across the various skeleton packages. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/luarocks')
-rw-r--r--package/luarocks/luarocks.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
index 656b832b9..eddd43540 100644
--- a/package/luarocks/luarocks.mk
+++ b/package/luarocks/luarocks.mk
@@ -60,5 +60,4 @@ define LUAROCKS_FINALIZE_TARGET
rm -rf $(TARGET_DIR)/usr/lib/luarocks
endef
-TARGET_FINALIZE_HOOKS += LUAROCKS_FINALIZE_TARGET
-
+LUAROCKS_TARGET_FINALIZE_HOOKS += LUAROCKS_FINALIZE_TARGET