summaryrefslogtreecommitdiff
path: root/package/lunit
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-02-24 08:34:58 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-01 16:52:54 +0100
commitfe465fb61f1298864534dcd3d675e4b25e0039fd (patch)
tree031bd6ea2803dd5b694458c5f27863653c931e20 /package/lunit
parentd05f5c983a0ccfac7a52f85054f1120db0281d65 (diff)
lunit: new package
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lunit')
-rw-r--r--package/lunit/Config.in10
-rw-r--r--package/lunit/lunit.mk13
2 files changed, 23 insertions, 0 deletions
diff --git a/package/lunit/Config.in b/package/lunit/Config.in
new file mode 100644
index 000000000..b3620efe2
--- /dev/null
+++ b/package/lunit/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LUNIT
+ bool "lunit"
+ depends on !BR2_PACKAGE_LUA_5_2
+ help
+ A unit testing framework for Lua.
+
+ http://www.mroth.net/lunit/
+
+comment "lunit needs a Lua 5.1 interpreter"
+ depends on BR2_PACKAGE_LUA_5_2
diff --git a/package/lunit/lunit.mk b/package/lunit/lunit.mk
new file mode 100644
index 000000000..1b5f43cee
--- /dev/null
+++ b/package/lunit/lunit.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# lunit
+#
+#############################################################
+
+LUNIT_VERSION_UPSTREAM = 0.5
+LUNIT_VERSION = $(LUNIT_VERSION_UPSTREAM)-2
+LUNIT_SUBDIR = lunit-$(LUNIT_VERSION_UPSTREAM)
+LUNIT_LICENSE = MIT
+LUNIT_LICENSE_FILES = $(LUNIT_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))