summaryrefslogtreecommitdiff
path: root/package/luv
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2015-07-28 22:03:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-21 16:03:59 +0200
commite512a4b9d00bf453e939279937db58afbe9d09e6 (patch)
tree3f9b692a99831cdf0a2f610c96b500f02644ce4a /package/luv
parentdab6765150e0eb5016869f3c0c0e0047745560e9 (diff)
luv: new package
libuv bindings for LuaJIT and Lua. [Thomas: - Move the package to the sub-menu of Lua modules. - Remove no longer needed dependency on BR2_PACKAGE_HAS_LUAINTERPRETER. - Propagate dependencies of libuv (mmu, !static, threads) - Update to upstream version 1.7.4-4. - Add hash file.] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/luv')
-rw-r--r--package/luv/Config.in14
-rw-r--r--package/luv/luv.hash2
-rw-r--r--package/luv/luv.mk30
3 files changed, 46 insertions, 0 deletions
diff --git a/package/luv/Config.in b/package/luv/Config.in
new file mode 100644
index 000000000..787d16269
--- /dev/null
+++ b/package/luv/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LUV
+ bool "luv"
+ select BR2_PACKAGE_LIBUV
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libuv
+ depends on BR2_USE_MMU # libuv
+ depends on !BR2_STATIC_LIBS # libuv
+ help
+ libuv bindings for LuaJIT and Lua.
+
+ https://github.com/luvit/luv
+
+comment "luv needs a toolchain w/ threads, dynamic library"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+ depends on BR2_USE_MMU
diff --git a/package/luv/luv.hash b/package/luv/luv.hash
new file mode 100644
index 000000000..307fc19a9
--- /dev/null
+++ b/package/luv/luv.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 9ea1c2343e76f653f8e7d3420d2c7718ef4eca67a645a9d17297ae91caa224b5 luv-1.7.4-4.tar.gz
diff --git a/package/luv/luv.mk b/package/luv/luv.mk
new file mode 100644
index 000000000..8e108a04b
--- /dev/null
+++ b/package/luv/luv.mk
@@ -0,0 +1,30 @@
+################################################################################
+#
+# luv
+#
+################################################################################
+
+LUV_VERSION = 1.7.4-4
+LUV_SOURCE = luv-$(LUV_VERSION).tar.gz
+LUV_SITE = https://github.com/luvit/luv/releases/download/$(LUV_VERSION)
+LUV_LICENSE = Apache-2.0
+LUV_LICENSE_FILE = LICENSE.txt
+LUV_DEPENDENCIES = libuv
+LUV_INSTALL_STAGING = YES
+
+LUV_CONF_OPTS += \
+ -DBUILD_MODULE=OFF \
+ -DWITH_SHARED_LIBUV=ON \
+ -DLUA_BUILD_TYPE=System
+
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+LUV_DEPENDENCIES += luajit
+LUV_CONF_OPTS += \
+ -DWITH_LUA_ENGINE=LuaJIT
+else
+LUV_DEPENDENCIES += lua
+LUV_CONF_OPTS += \
+ -DWITH_LUA_ENGINE=Lua
+endif
+
+$(eval $(cmake-package))