summaryrefslogtreecommitdiff
path: root/package/lxc
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 18:34:58 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 21:28:55 +0100
commit2e461df5dd0cc37bde6908a932528a74a512636d (patch)
tree02f712360c3f21701c86766bc5c2bf520e6fa64f /package/lxc
parent82efed68dad1831056aeba502641124bdc7ed6c7 (diff)
package/lxc: add optional support for libseccomp
When libseccomp was compiled before, lxc will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/libexec/lxc/lxc-monitord | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [liblxc.so.1] 0x0000000000000001 (NEEDED) Shared library: [libcap.so.2] 0x0000000000000001 (NEEDED) Shared library: [libseccomp.so.2] [...] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lxc')
-rw-r--r--package/lxc/lxc.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
index e382f4dec..819096959 100644
--- a/package/lxc/lxc.mk
+++ b/package/lxc/lxc.mk
@@ -15,4 +15,11 @@ LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
--disable-lua --disable-python \
$(if $(BR2_PACKAGE_BASH),,--disable-bash)
+ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
+LXC_CONF_OPTS += --enable-seccomp
+LXC_DEPENDENCIES += libseccomp
+else
+LXC_CONF_OPTS += --disable-seccomp
+endif
+
$(eval $(autotools-package))