summaryrefslogtreecommitdiff
path: root/package/lxc
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2016-12-18 12:04:52 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-18 12:32:11 +0100
commitc383856268b2088d476932f11cfcacab3b085d58 (patch)
tree1d62bf533d2eecbf8b3231d34f9cc13a69557549 /package/lxc
parentbe2adc1ab28a9b255068c3786b63406b482ed286 (diff)
lxc: enable lua if package is selected
lua and python bindings were removed with the same patch: https://patchwork.ozlabs.org/patch/367361. There is a real issue with python but not with lua so enable it if lua is selected Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com> [Thomas: simplify value passed to --with-lua-pc.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lxc')
-rw-r--r--package/lxc/lxc.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
index 589930f1a..e9e925f44 100644
--- a/package/lxc/lxc.mk
+++ b/package/lxc/lxc.mk
@@ -10,7 +10,7 @@ LXC_LICENSE = LGPLv2.1+
LXC_LICENSE_FILES = COPYING
LXC_DEPENDENCIES = libcap host-pkgconf
LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
- --disable-lua --disable-python --disable-werror \
+ --disable-python --disable-werror \
$(if $(BR2_PACKAGE_BASH),,--disable-bash)
ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
@@ -20,4 +20,15 @@ else
LXC_CONF_OPTS += --disable-seccomp
endif
+ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
+LXC_CONF_OPTS += --enable-lua
+LXC_DEPENDENCIES += luainterpreter
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+# By default, lxc will only search for lua.pc
+LXC_CONF_OPTS += --with-lua-pc=luajit
+endif
+else
+LXC_CONF_OPTS += --disable-lua
+endif
+
$(eval $(autotools-package))