summaryrefslogtreecommitdiff
path: root/package/lxc
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2016-12-19 16:26:18 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-01-30 16:08:24 +0100
commitcc6091caea67e8a9144f0f2602ddb2798eb725cb (patch)
tree66c367c869e3644cdbe62d318c5147ba7ae8e6db /package/lxc
parent8c43f5fd37e2cb4298c042b07b1ba017ebcd9256 (diff)
lxc: add optional dependency on gnutls
lxc can use gnutls for various checksumming so add a dependency on it if package is selected Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/lxc')
-rw-r--r--package/lxc/lxc.hash1
-rw-r--r--package/lxc/lxc.mk14
2 files changed, 15 insertions, 0 deletions
diff --git a/package/lxc/lxc.hash b/package/lxc/lxc.hash
index 7b34e8833..8fb4dc0cc 100644
--- a/package/lxc/lxc.hash
+++ b/package/lxc/lxc.hash
@@ -1,2 +1,3 @@
# Locally calculated
sha256 7c292cd0055dac1a0e6fbb6a7740fd12b6ffb204603c198faf37c11c9d6dcd7a lxc-2.0.6.tar.gz
+sha256 e8ca30fb1e8d6dbafb5cccc04b3fd1784c35bc8ccf79112036e5166924b6b01d 64fa248372c90c9d98fc9d67f80327d865c11a48.patch
diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
index e9e925f44..34a855636 100644
--- a/package/lxc/lxc.mk
+++ b/package/lxc/lxc.mk
@@ -9,10 +9,24 @@ LXC_SITE = https://linuxcontainers.org/downloads/lxc
LXC_LICENSE = LGPLv2.1+
LXC_LICENSE_FILES = COPYING
LXC_DEPENDENCIES = libcap host-pkgconf
+# we're patching configure.ac
+LXC_AUTORECONF = YES
+
+# This patch adds --enable-gnutls option
+LXC_PATCH = \
+ https://github.com/lxc/lxc/commit/64fa248372c90c9d98fc9d67f80327d865c11a48.patch
+
LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
--disable-python --disable-werror \
$(if $(BR2_PACKAGE_BASH),,--disable-bash)
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+LXC_CONF_OPTS += --enable-gnutls
+LXC_DEPENDENCIES += gnutls
+else
+LXC_CONF_OPTS += --disable-gnutls
+endif
+
ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
LXC_CONF_OPTS += --enable-seccomp
LXC_DEPENDENCIES += libseccomp