summaryrefslogtreecommitdiff
path: root/package/lxc
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-02-12 12:21:26 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-08-13 23:09:34 +0200
commitf62a006639bb4222027415bee7193061ca1c514c (patch)
tree39b6e8d8a9d2799253bc4e22d3140e8b00309bb4 /package/lxc
parentbda69bf4e4b642ab199ffa13c7356709885f129d (diff)
lxc: new package
Linux Containers (LXC), provides the ability to group and isolate of a set of processes in a jail by virtualizing and accounting the kernel resources. It is similar to Linux-Vserver or Openvz. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lxc')
-rw-r--r--package/lxc/Config.in14
-rw-r--r--package/lxc/lxc.mk14
2 files changed, 28 insertions, 0 deletions
diff --git a/package/lxc/Config.in b/package/lxc/Config.in
new file mode 100644
index 000000000..5e6e20815
--- /dev/null
+++ b/package/lxc/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LXC
+ bool "lxc"
+ select BR2_PACKAGE_LIBCAP
+ depends on BR2_INET_IPV6
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ Linux Containers (LXC), provides the ability to group and isolate
+ of a set of processes in a jail by virtualizing and accounting the
+ kernel resources. It is similar to Linux-Vserver or Openvz.
+
+ http://lxc.sourceforge.net/
+
+comment "lxc requires a toolchain with IPv6 and thread support"
+ depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
new file mode 100644
index 000000000..4e069029d
--- /dev/null
+++ b/package/lxc/lxc.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lxc
+#
+################################################################################
+
+LXC_VERSION = 0.9.0
+LXC_SITE = http://downloads.sourceforge.net/project/lxc/lxc/lxc-$(LXC_VERSION)
+LXC_LICENSE = LGPLv2.1+
+LXC_LICENSE_FILES = COPYING
+LXC_DEPENDENCIES = libcap
+LXC_CONF_OPT = --disable-apparmor
+
+$(eval $(autotools-package))