summaryrefslogtreecommitdiff
path: root/package/lz4
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-29 23:17:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-29 23:17:06 +0100
commitc8cca4c192e1890b2f1fbe422d8b63e405b46f67 (patch)
tree9f04c757e5c591ed02a877be36a1393f238ff320 /package/lz4
parent2661c4f1b715d4ea3df41c4c86373f64bf4a5b6b (diff)
package/lz4: only use PREFIX for host installation
As noted by Peter Korsgaard, using DESTDIR=$(HOST_DIR) and PREFIX=/usr for the host installation is useless and actually incorrect (the pkg-config file contains incorrect paths). Instead, using PREFIX=$(HOST_DIR)/usr is simpler, and actually correct. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lz4')
-rw-r--r--package/lz4/lz4.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/lz4/lz4.mk b/package/lz4/lz4.mk
index 576b2a227..d2b09bbae 100644
--- a/package/lz4/lz4.mk
+++ b/package/lz4/lz4.mk
@@ -22,8 +22,8 @@ define HOST_LZ4_BUILD_CMDS
endef
define HOST_LZ4_INSTALL_CMDS
- $(MAKE) $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR) \
- PREFIX=/usr install -C $(@D)
+ $(MAKE) $(HOST_CONFIGURE_OPTS) PREFIX=$(HOST_DIR)/usr \
+ install -C $(@D)
endef
define LZ4_BUILD_CMDS