summaryrefslogtreecommitdiff
path: root/package/lzip
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-03-01 16:04:15 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-03-01 21:01:11 +0100
commit46416950caac37a16f2c34c77be3ac2b046f266c (patch)
treee1ef5e6c59d40f31908d9e247106069d620ac024 /package/lzip
parent25c438bce1c02775f2c23d8878ab71c3022b0c95 (diff)
lzip: new package
The host variant is in preparation for possibly some gnu packages shipping tar.lz versions only. At least ed 1.10 did it (still needed to add extraction support for it). Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lzip')
-rw-r--r--package/lzip/Config.in15
-rw-r--r--package/lzip/lzip.mk40
2 files changed, 55 insertions, 0 deletions
diff --git a/package/lzip/Config.in b/package/lzip/Config.in
new file mode 100644
index 000000000..b72ac7851
--- /dev/null
+++ b/package/lzip/Config.in
@@ -0,0 +1,15 @@
+comment "lzip needs a toolchain w/ C++, largefile"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_LARGEFILE)
+
+config BR2_PACKAGE_LZIP
+ bool "lzip"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_LARGEFILE
+ help
+ Lzip is a lossless data compressor with a user interface similar
+ to the one of gzip or bzip2.
+ Lzip is about as fast as gzip, compresses most files more than
+ bzip2, and is better than both from a data recovery perspective.
+ Lzip is a clean implementation of the LZMA algorithm.
+
+ http://savannah.nongnu.org/projects/lzip
diff --git a/package/lzip/lzip.mk b/package/lzip/lzip.mk
new file mode 100644
index 000000000..0aa705118
--- /dev/null
+++ b/package/lzip/lzip.mk
@@ -0,0 +1,40 @@
+################################################################################
+#
+# lzip
+#
+################################################################################
+
+LZIP_VERSION = 1.15
+LZIP_SITE = http://download.savannah.gnu.org/releases/lzip/
+LZIP_LICENSE = GPLv3+
+LZIP_LICENSE_FILES = COPYING
+
+define LZIP_CONFIGURE_CMDS
+ (cd $(@D); ./configure --prefix=/usr \
+ $(TARGET_CONFIGURE_OPTS) )
+endef
+
+define HOST_LZIP_CONFIGURE_CMDS
+ (cd $(@D); ./configure --prefix=/usr \
+ $(HOST_CONFIGURE_OPTS) )
+endef
+
+define LZIP_BUILD_CMDS
+ $(MAKE) -C $(@D)
+endef
+
+define HOST_LZIP_BUILD_CMDS
+ $(MAKE) -C $(@D)
+endef
+
+define LZIP_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+define HOST_LZIP_INSTALL_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(HOST_DIR) install
+endef
+
+# It's not autotools-based
+$(eval $(generic-package))
+$(eval $(host-generic-package))