summaryrefslogtreecommitdiff
path: root/package/makedevs
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-11-23 15:14:04 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-23 23:12:06 +0100
commit207294ffa9bbc0a01476646ed37afbd866b74191 (patch)
tree4d513f92840970f381e67e2a33d65531b6f28cdc /package/makedevs
parent3111f6a5109678fa08be44792b4708fd7d09eb4f (diff)
makedevs: remove target package
The makedevs package is a fork of the makedevs tool from busybox. It is part of the Buildroot infrastructure, not something that should be used on the target. It something like this is needed on the target, upstream busybox should be used. And if one of the Buildroot-specific features is needed, then that feature should be upstreamed to busybox. Besides, there were already two things wrong with the target package: - it didn't take into account the overlap with busybox (no depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS, no dependency on busybox); - it didn't take into account the libcap feature. The target package was introduced more or less accidentally in 81cd9d45 where the intention was to make it more similar to other packages. So, kill it with fire. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/makedevs')
-rw-r--r--package/makedevs/Config.in5
-rw-r--r--package/makedevs/makedevs.mk10
2 files changed, 0 insertions, 15 deletions
diff --git a/package/makedevs/Config.in b/package/makedevs/Config.in
deleted file mode 100644
index 923150dd6..000000000
--- a/package/makedevs/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_PACKAGE_MAKEDEVS
- bool "makedevs"
- help
- The makedevs utility allows to create a set of device files
- according to a configuration file.
diff --git a/package/makedevs/makedevs.mk b/package/makedevs/makedevs.mk
index 95933c4f4..9bd684f03 100644
--- a/package/makedevs/makedevs.mk
+++ b/package/makedevs/makedevs.mk
@@ -15,15 +15,6 @@ HOST_MAKEDEVS_CFLAGS += -DEXTENDED_ATTRIBUTES
HOST_MAKEDEVS_LDFLAGS += -lcap
endif
-define MAKEDEVS_BUILD_CMDS
- $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
- package/makedevs/makedevs.c -o $(@D)/makedevs
-endef
-
-define MAKEDEVS_INSTALL_TARGET_CMDS
- $(INSTALL) -D -m 755 $(@D)/makedevs $(TARGET_DIR)/usr/sbin/makedevs
-endef
-
define HOST_MAKEDEVS_BUILD_CMDS
$(HOSTCC) $(HOST_MAKEDEVS_CFLAGS) package/makedevs/makedevs.c \
-o $(@D)/makedevs $(HOST_MAKEDEVS_LDFLAGS)
@@ -33,5 +24,4 @@ define HOST_MAKEDEVS_INSTALL_CMDS
$(INSTALL) -D -m 755 $(@D)/makedevs $(HOST_DIR)/usr/bin/makedevs
endef
-$(eval $(generic-package))
$(eval $(host-generic-package))