summaryrefslogtreecommitdiff
path: root/package/makedevs
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-06-11 21:12:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 19:10:18 +0200
commitad406f612744151834c738183162ce557b75e41e (patch)
tree90be417f52772c20c7db1af07e168e607cb213e5 /package/makedevs
parent9a8ec9195c4f035dfb315267c2da92cc4b6e96a3 (diff)
makedevs: change version from 'undefined' to 'buildroot-$(BR2_VERSION)'
The sources of the makedevs package are shipped with Buildroot, rather than downloaded from an external location. As a result, no explicit version is defined, causing build messages and build directory to show 'undefined' as version. This patch sets the version for makedevs to 'buildroot-$(BR2_VERSION), which would for example expand to 'buildroot-2014.05'. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/makedevs')
-rw-r--r--package/makedevs/makedevs.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/makedevs/makedevs.mk b/package/makedevs/makedevs.mk
index ff91c4a89..7210dc6c2 100644
--- a/package/makedevs/makedevs.mk
+++ b/package/makedevs/makedevs.mk
@@ -8,6 +8,8 @@
MAKEDEVS_SOURCE =
HOST_MAKEDEVS_SOURCE =
+MAKEDEVS_VERSION = buildroot-$(BR2_VERSION)
+
define MAKEDEVS_BUILD_CMDS
$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
package/makedevs/makedevs.c -o $(@D)/makedevs