summaryrefslogtreecommitdiff
path: root/package/matchbox-panel
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-06-03 22:41:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-09 23:02:31 +0200
commit3b468acbb4ec2aca748fc022ff0d53a530b3264b (patch)
tree08f312289bb132bcb62d974852dc3d66529f873b /package/matchbox-panel
parent390ef4ebb441c263f16572e458c71bde35d01c58 (diff)
package/matchbox-common: move one directory higher
We usually do not have a sub-directory for a family of related packages, so move matchbox packages one directory higher, so they all are in packages/ Also re-order packages alphabetically. Reported-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/matchbox-panel')
-rw-r--r--package/matchbox-panel/0001-index-is-legacy.patch20
-rw-r--r--package/matchbox-panel/0002-mb-applet-wireless.patch34
-rw-r--r--package/matchbox-panel/Config.in6
-rw-r--r--package/matchbox-panel/matchbox-panel.hash2
-rw-r--r--package/matchbox-panel/matchbox-panel.mk27
5 files changed, 89 insertions, 0 deletions
diff --git a/package/matchbox-panel/0001-index-is-legacy.patch b/package/matchbox-panel/0001-index-is-legacy.patch
new file mode 100644
index 000000000..925c326e7
--- /dev/null
+++ b/package/matchbox-panel/0001-index-is-legacy.patch
@@ -0,0 +1,20 @@
+Replace the legacy index() with strchr()
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ applets/mb-applet-menu-launcher.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: matchbox-panel-0.9.3/applets/mb-applet-menu-launcher.c
+===================================================================
+--- matchbox-panel-0.9.3.orig/applets/mb-applet-menu-launcher.c
++++ matchbox-panel-0.9.3/applets/mb-applet-menu-launcher.c
+@@ -280,7 +280,7 @@
+ DBG("\tkey %s ", key);
+ if (*(++p) == '"') { p++; tc = sc; } /* skip "'s */
+ val = p;
+- while(index(tc,*p) == NULL)
++ while(strchr(tc,*p) == NULL)
+ {
+ if (*p == '\\' && *(p+1) == '"') p++; /* skip \" */
+ p++;
diff --git a/package/matchbox-panel/0002-mb-applet-wireless.patch b/package/matchbox-panel/0002-mb-applet-wireless.patch
new file mode 100644
index 000000000..93633b367
--- /dev/null
+++ b/package/matchbox-panel/0002-mb-applet-wireless.patch
@@ -0,0 +1,34 @@
+mb-applet-wireless: fix undefined reference to `log' and `lrint'
+
+mb-applet-wireless.o: In function `update_wireless':
+.. matchbox-panel-0.9.3/applets/mb-applet-wireless.c:143: undefined reference to `log'
+.. matchbox-panel-0.9.3/applets/mb-applet-wireless.c:143: undefined reference to `lrint'
+
+Signed-off-by: Jean-Paul Etienne <fractalclone@gmail.com>
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+[arnout: add description and Signed-off-by]
+---
+diff -rup matchbox-panel-0.9.3.orig/applets/Makefile.in matchbox-panel-0.9.3/applets/Makefile.in
+--- matchbox-panel-0.9.3.orig/applets/Makefile.in 2015-01-23 00:16:47.594850985 +0100
++++ matchbox-panel-0.9.3/applets/Makefile.in 2015-01-23 00:15:18.458694947 +0100
+@@ -198,7 +198,7 @@ WANT_SMALL_ICONS_FALSE = @WANT_SMALL_ICO
+ WANT_SMALL_ICONS_TRUE = @WANT_SMALL_ICONS_TRUE@
+ WANT_WIFI_FALSE = @WANT_WIFI_FALSE@
+ WANT_WIFI_TRUE = @WANT_WIFI_TRUE@
+-WIRELESS_LIBS = @WIRELESS_LIBS@
++WIRELESS_LIBS = @WIRELESS_LIBS@ -lm
+ XGETTEXT = @XGETTEXT@
+ ac_ct_CC = @ac_ct_CC@
+ ac_ct_STRIP = @ac_ct_STRIP@
+diff -rup matchbox-panel-0.9.3.orig/applets/mb-applet-wireless.c matchbox-panel-0.9.3/applets/mb-applet-wireless.c
+--- matchbox-panel-0.9.3.orig/applets/mb-applet-wireless.c 2015-01-23 00:16:31.531822865 +0100
++++ matchbox-panel-0.9.3/applets/mb-applet-wireless.c 2015-01-23 00:03:43.067563827 +0100
+@@ -50,6 +50,8 @@
+
+ #endif
+
++#include <math.h>
++
+ #ifdef MB_HAVE_PNG
+ #define IMG_EXT "png"
+ #else
diff --git a/package/matchbox-panel/Config.in b/package/matchbox-panel/Config.in
new file mode 100644
index 000000000..e3daaf5fa
--- /dev/null
+++ b/package/matchbox-panel/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MATCHBOX_PANEL
+ bool "Matchbox Panel"
+ select BR2_PACKAGE_MATCHBOX_LIB
+ help
+ A flexible always present 'window bar' for holding
+ application launchers.
diff --git a/package/matchbox-panel/matchbox-panel.hash b/package/matchbox-panel/matchbox-panel.hash
new file mode 100644
index 000000000..82802a998
--- /dev/null
+++ b/package/matchbox-panel/matchbox-panel.hash
@@ -0,0 +1,2 @@
+# From http://downloads.yoctoproject.org/releases/matchbox/matchbox-panel/0.9/matchbox-panel-0.9.3.tar.bz2.md5
+md5 56d1807636f3919e22e51896ab7ccd2e matchbox-panel-0.9.3.tar.bz2
diff --git a/package/matchbox-panel/matchbox-panel.mk b/package/matchbox-panel/matchbox-panel.mk
new file mode 100644
index 000000000..f7d699bda
--- /dev/null
+++ b/package/matchbox-panel/matchbox-panel.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# matchbox-panel
+#
+################################################################################
+
+MATCHBOX_PANEL_VERSION_MAJOR = 0.9
+MATCHBOX_PANEL_VERSION = $(MATCHBOX_PANEL_VERSION_MAJOR).3
+MATCHBOX_PANEL_SOURCE = matchbox-panel-$(MATCHBOX_PANEL_VERSION).tar.bz2
+MATCHBOX_PANEL_SITE = http://downloads.yoctoproject.org/releases/matchbox/matchbox-panel/$(MATCHBOX_PANEL_VERSION_MAJOR)
+MATCHBOX_PANEL_LICENSE = GPLv2+
+MATCHBOX_PANEL_LICENSE_FILES = COPYING
+MATCHBOX_PANEL_DEPENDENCIES = matchbox-lib
+MATCHBOX_PANEL_CONF_OPTS = --enable-expat
+
+ifeq ($(BR2_PACKAGE_MATCHBOX_STARTUP_MONITOR),y)
+MATCHBOX_PANEL_CONF_OPTS += --enable-startup-notification
+MATCHBOX_PANEL_DEPENDENCIES += matchbox-startup-monitor
+else
+MATCHBOX_PANEL_CONF_OPTS += --disable-startup-notification
+endif
+
+ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS),y)
+MATCHBOX_PANEL_DEPENDENCIES += wireless_tools
+endif
+
+$(eval $(autotools-package))