summaryrefslogtreecommitdiff
path: root/package/matchbox
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-06-03 22:41:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-09 23:06:59 +0200
commitd890098d0510b6ae6f53be34eb48d5cbc50d8bdf (patch)
tree9ea97a00b3bb93b86a4b8e87abbc84e45c20e371 /package/matchbox
parent14b6ea282fe85e41f1ae7a37c687440f1bcf1642 (diff)
package/matchbox: drop useless dependencies
xlib-libXft is only needed when building a 'standalone' matchbox, which means not using matchbox-lib. But we *are* building matchbox-lib, and we do not support the standalone mode (and probably won't, as even upstream says it is ugly, by lack of theming). Similarly, xlib-libXext is only used for its 'xsync' extension, for which support is entirely commented-out in matchbox. So, drop the dependency on xlib-libXft, and make it explicit we're not building either standalone modes; drop xlib-libXext. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/matchbox')
-rw-r--r--package/matchbox/Config.in1
-rw-r--r--package/matchbox/matchbox.mk11
2 files changed, 6 insertions, 6 deletions
diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
index d42b90fbf..0c7e5ea9f 100644
--- a/package/matchbox/Config.in
+++ b/package/matchbox/Config.in
@@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
depends on BR2_USE_MMU # fork()
select BR2_PACKAGE_FONTCONFIG
select BR2_PACKAGE_EXPAT
- select BR2_PACKAGE_XLIB_LIBXEXT
select BR2_PACKAGE_XLIB_LIBXCURSOR
select BR2_PACKAGE_MATCHBOX_LIB
help
diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
index b1f96a6e5..1abcfd848 100644
--- a/package/matchbox/matchbox.mk
+++ b/package/matchbox/matchbox.mk
@@ -11,15 +11,16 @@ MATCHBOX_LICENSE = GPLv2+
MATCHBOX_LICENSE_FILES = COPYING
MATCHBOX_DEPENDENCIES = matchbox-lib
-MATCHBOX_CONF_OPTS = --enable-expat --disable-gconf --disable-composite
+MATCHBOX_CONF_OPTS = \
+ --enable-expat \
+ --disable-gconf \
+ --disable-composite \
+ --disable-standalone \
+ --disable-standalone-xft
# Workaround bug in configure script
MATCHBOX_CONF_ENV = expat=yes
-ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
-MATCHBOX_DEPENDENCIES += xlib_libXft
-endif
-
ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
MATCHBOX_CONF_OPTS += --enable-startup-notification
MATCHBOX_DEPENDENCIES += startup-notification