summaryrefslogtreecommitdiff
path: root/package/mc
diff options
context:
space:
mode:
authorMauro Condarelli <mc5686@mclink.it>2015-03-24 20:57:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-29 15:31:23 +0200
commit21388e3073deede4045d4660f3f0b838aab773d6 (patch)
tree81f45740c5b6bfcde9fcf7a16fe02ed4bb0a6e6c /package/mc
parente009cbc0a5aeefcb8cc6c7b763bab0d834ba2938 (diff)
mc: new package
[Thomas: fix license, it is actually GPLv3+, not GPLv3.] Signed-off-by: Mauro Condarelli <mc5686@mclink.it> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mc')
-rw-r--r--package/mc/Config.in19
-rw-r--r--package/mc/mc.hash2
-rw-r--r--package/mc/mc.mk25
3 files changed, 46 insertions, 0 deletions
diff --git a/package/mc/Config.in b/package/mc/Config.in
new file mode 100644
index 000000000..7030b5f1a
--- /dev/null
+++ b/package/mc/Config.in
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_MC
+ bool "mc"
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+ depends on BR2_USE_MMU # libglib2, slang
+ select BR2_PACKAGE_LIBGLIB2
+ # mc prefers slang, but can use ncurses too
+ select BR2_PACKAGE_SLANG if !BR2_PACKAGE_NCURSES
+ help
+ GNU Midnight Commander is a visual file manager, licensed under
+ GNU General Public License. It can use either SLang (preferred)
+ or ncurses for screen handling; if neither is enabled SLang
+ will be automatically chosen.
+
+ https://www.midnight-commander.org
+
+comment "mc needs a toolchain w/ threads, wchar"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+ depends on BR2_USE_MMU
diff --git a/package/mc/mc.hash b/package/mc/mc.hash
new file mode 100644
index 000000000..588bbaa9b
--- /dev/null
+++ b/package/mc/mc.hash
@@ -0,0 +1,2 @@
+# Hash from http://ftp.midnight-commander.org/mc-4.8.14.sha256:
+sha256 61fd0fd2280c3d09d7e0aec8ab001fc89dad8e4fd9941f386414667b55152ec5 mc-4.8.14.tar.bz2
diff --git a/package/mc/mc.mk b/package/mc/mc.mk
new file mode 100644
index 000000000..9e65e4937
--- /dev/null
+++ b/package/mc/mc.mk
@@ -0,0 +1,25 @@
+################################################################################
+#
+# mc
+#
+################################################################################
+
+MC_VERSION = 4.8.14
+MC_SOURCE = mc-$(MC_VERSION).tar.bz2
+MC_SITE = http://ftp.midnight-commander.org
+MC_LICENSE = GPLv3+
+MC_LICENSE_FILES = COPYING
+MC_DEPENDENCIES = libglib2 host-pkgconf
+
+# mc prefers slang, so use that if enabled, otherwise
+# fallback to using ncurses.
+# Either or both will be enabled, but we prefer slang.
+ifeq ($(BR2_PACKAGE_SLANG),y)
+MC_DEPENDENCIES += slang
+MC_CONF_OPTS += --with-screen=slang
+else
+MC_DEPENDENCIES += ncurses
+MC_CONF_OPTS += --with-screen=ncurses
+endif
+
+$(eval $(autotools-package))