summaryrefslogtreecommitdiff
path: root/package/menu-cache
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2014-11-21 15:33:08 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-13 02:16:09 +0200
commit91489ddc48c439004e718667f117fce391658577 (patch)
tree882cb8a1a53e48ce431dce0736b1dbe83e7bb73c /package/menu-cache
parente5d3c5abde69d3d085d496747c0da4c5852ce188 (diff)
menu-cache: new package
[Thomas: - Remove the MENU_CACHE_VERSION_MINOR variable, not needed. Noticed by Yann E. Morin. - Rewrap Config.in help text.] Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/menu-cache')
-rw-r--r--package/menu-cache/Config.in16
-rw-r--r--package/menu-cache/menu-cache.hash2
-rw-r--r--package/menu-cache/menu-cache.mk16
3 files changed, 34 insertions, 0 deletions
diff --git a/package/menu-cache/Config.in b/package/menu-cache/Config.in
new file mode 100644
index 000000000..b75c8ec05
--- /dev/null
+++ b/package/menu-cache/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_MENU_CACHE
+ bool "menu-cache"
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_LIBFM_EXTRA
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+ depends on BR2_USE_MMU # libglib2
+ help
+ Small library from LXDE project used for application menu
+ integration
+
+ http://wiki.lxde.org/
+
+comment "menu-cache needs a toolchain w/ wchar, threads"
+ depends on BR2_USE_MMU
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/menu-cache/menu-cache.hash b/package/menu-cache/menu-cache.hash
new file mode 100644
index 000000000..3b9e5c42c
--- /dev/null
+++ b/package/menu-cache/menu-cache.hash
@@ -0,0 +1,2 @@
+# From http://blog.lxde.org/?p=1299
+sha1 e7b3854109f9826472cf9795e924acebe5e27861 menu-cache-1.0.0.tar.xz
diff --git a/package/menu-cache/menu-cache.mk b/package/menu-cache/menu-cache.mk
new file mode 100644
index 000000000..9d4386434
--- /dev/null
+++ b/package/menu-cache/menu-cache.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# menu-cache
+#
+################################################################################
+
+MENU_CACHE_VERSION_MAJOR = 1.0
+MENU_CACHE_VERSION = $(MENU_CACHE_VERSION_MAJOR).0
+MENU_CACHE_SOURCE = menu-cache-$(MENU_CACHE_VERSION).tar.xz
+MENU_CACHE_SITE = http://sourceforge.net/projects/lxde/files/menu-cache/$(MENU_CACHE_VERSION_MAJOR)
+MENU_CACHE_DEPENDENCIES = libfm-extra libglib2
+MENU_CACHE_LICENSE = LGPLv2.1
+MENU_CACHE_LICENSE_FILES = COPYING
+MENU_CACHE_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))