summaryrefslogtreecommitdiff
path: root/package/micropython
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2015-09-18 21:19:35 +1200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-19 14:00:15 +0200
commit4685485ef7651786da87f0e09a7d787aae68c1fe (patch)
tree01f3d2dbd46fd5f8259986c224ec9f27d153bf3e /package/micropython
parent15809ab132bd3e2c592e67364f0311604843b792 (diff)
micropython: Set MICROPY_GCREGS_SETJMP=1 for xtensa and sh
These architectures don't have explicit exception handling support in micropython but can use the setjmp fallback behaviour instead. Signed-off-by: Chris Packham <judge.packham@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/micropython')
-rw-r--r--package/micropython/micropython.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index 2d7c92407..62668828a 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -12,7 +12,7 @@ MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
# Use fallback implementation for exception handling on architectures that don't
# have explicit support.
-ifeq ($(BR2_powerpc),y)
+ifeq ($(BR2_powerpc)$(BR2_sh)$(BR2_xtensa),y)
MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
endif