summaryrefslogtreecommitdiff
path: root/package/micropython
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2015-09-20 20:44:35 +1200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-20 14:26:03 +0200
commitbccecbe1e65fa8d63251175feea405d6c665ae57 (patch)
treea8ec1d2ee19a3d0ede35a4cdae4cc7a2c0ed4e71 /package/micropython
parent453e1904224591b44041608a48f717f6448fe959 (diff)
micropython: Add upstream patch to fix 64-bit builds
Fixes the following error when building for a 64-bit target ../py/objint_mpz.c:54:5: error: right shift count >= width of type [-Werror] (MP_SSIZE_MAX >> MPZ_DIG_SIZE * 4) & DIG_MASK, ^ ../py/objint_mpz.c:54:5: error: initializer element is not constant ../py/objint_mpz.c:54:5: error: (near initialization for 'maxsize_dig[4]') Signed-off-by: Chris Packham <judge.packham@gmail.com> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/micropython')
-rw-r--r--package/micropython/micropython.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index 62668828a..f2ad5bf64 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -9,6 +9,7 @@ MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
MICROPYTHON_LICENSE = MIT
MICROPYTHON_LICENSE_FILES = LICENSE
MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
+MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8b4fb4fe140e9cf57fcfa258d0d2d6fe19090fc5.patch
# Use fallback implementation for exception handling on architectures that don't
# have explicit support.