summaryrefslogtreecommitdiff
path: root/package/minidlna
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-07-24 20:38:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-26 15:17:08 +0200
commit889a4a8d4f609f9e3c33afc8953d045255ef2b54 (patch)
tree72488ed515ebdd8f11ab3080c80c654ad5b4c29e /package/minidlna
parent23c3919c5e5b4fa69af9d16ce6a9286869740fd3 (diff)
package/minidlna: Fix static compile
Fixes http://autobuild.buildroot.net/results/aeb/aeb5481526497a01ada8ee9403f282a2374b0383/ http://autobuild.buildroot.net/results/255/25536df514477f3210caf4af27f2f107683f7fb2/ http://autobuild.buildroot.net/results/fa1/fa11cb360190b02d08e74997b0abc73079760dfa/ and many others This is a follow-up for these patches: http://patchwork.ozlabs.org/patch/493360/ http://patchwork.ozlabs.org/patch/416007/ [Thomas: - don't pass --static to pkg-config, since our pkg-config wrapper already passes it automatically when BR2_STATIC_LIBS=y. - make only one call to pkg-config for all three libraries - put the libintl logic separately from the definition of MINIDLNA_CONF_ENV.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/minidlna')
-rw-r--r--package/minidlna/minidlna.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/minidlna/minidlna.mk b/package/minidlna/minidlna.mk
index 3a9ad4165..ab9348467 100644
--- a/package/minidlna/minidlna.mk
+++ b/package/minidlna/minidlna.mk
@@ -17,8 +17,9 @@ MINIDLNA_DEPENDENCIES = \
ifeq ($(BR2_STATIC_LIBS),y)
# the configure script / Makefile forgets to link with some of the dependent
# libraries breaking static linking, so help it along
-MINIDLNA_CONF_ENV = \
- LIBS='-lavformat -lavcodec -lavutil -logg -lz -lpthread -lm'
+MINIDLNA_STATIC_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libavcodec libexif libvorbis`
+MINIDLNA_STATIC_LIBS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)
+MINIDLNA_CONF_ENV += LIBS="$(MINIDLNA_STATIC_LIBS)"
else
MINIDLNA_CONF_OPTS = \
--disable-static