summaryrefslogtreecommitdiff
path: root/package/mmc-utils
diff options
context:
space:
mode:
authorSébastien Szymanski <sebastien.szymanski@armadeus.com>2014-01-15 13:55:54 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-15 15:00:46 +0100
commit84179df8ae19657228583a394675a19eb96e8b8c (patch)
tree8ed6a870942bcf6fbe37edd9913bcf9ba5a50c31 /package/mmc-utils
parentab5c9c36ca5e8f62ae2fae2e3510d5923d888e52 (diff)
mmc-utils: new package
mmc-utils provides tools to manipulate mmc device registers. [Peter: drop uninstall, move to filesystem and flash utilities] Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mmc-utils')
-rw-r--r--package/mmc-utils/Config.in10
-rw-r--r--package/mmc-utils/mmc-utils.mk19
2 files changed, 29 insertions, 0 deletions
diff --git a/package/mmc-utils/Config.in b/package/mmc-utils/Config.in
new file mode 100644
index 000000000..07650c8a1
--- /dev/null
+++ b/package/mmc-utils/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MMC_UTILS
+ bool "mmc-utils"
+ depends on BR2_LARGEFILE
+ help
+ MMC utils
+
+ https://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git
+
+comment "mmc-utils needs a toolchain w/ largefile"
+ depends on !BR2_LARGEFILE
diff --git a/package/mmc-utils/mmc-utils.mk b/package/mmc-utils/mmc-utils.mk
new file mode 100644
index 000000000..372d8402a
--- /dev/null
+++ b/package/mmc-utils/mmc-utils.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# mmc-utils
+#
+################################################################################
+
+MMC_UTILS_VERSION = 11f2ceabc4ad3f0dd568e0ce68166e4803e0615b
+MMC_UTILS_SITE = git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git
+MMC_UTILS_LICENSE = GPLv2
+
+define MMC_UTILS_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define MMC_UTILS_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/mmc $(TARGET_DIR)/usr/bin/mmc
+endef
+
+$(eval $(generic-package))