summaryrefslogtreecommitdiff
path: root/package/moarvm
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-11-23 14:39:10 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-25 22:41:58 +0100
commit40cbdf6de070db116e44a52b4a232d24ce850186 (patch)
tree106a238b64fc40033f049dbd0a6c2f5f247e23e9 /package/moarvm
parent23b949fdb0f7a4d2582929defa8c17ff5b1a5d1a (diff)
moarvm: use pkgconfig to find libraries and headers
MoarVM's Configure.pl script uses pkgconfig to find libraries and headers, but it uses the one installed in the host machine which is wrong and can lead to errors of unsafe include paths. Instead, make it depend on the host-pkgconf package and specify the path to our pkgconfig binary by using the --pkgconfig configure option. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/moarvm')
-rw-r--r--package/moarvm/moarvm.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/moarvm/moarvm.mk b/package/moarvm/moarvm.mk
index 644432eda..80bd19c92 100644
--- a/package/moarvm/moarvm.mk
+++ b/package/moarvm/moarvm.mk
@@ -10,7 +10,7 @@ MOARVM_SOURCE = MoarVM-$(MOARVM_VERSION).tar.gz
MOARVM_LICENSE = Artistic-2.0
MOARVM_LICENSE_FILES = Artistic2.txt
MOARVM_INSTALL_STAGING = YES
-MOARVM_DEPENDENCIES = host-luajit libuv libtommath libatomic_ops
+MOARVM_DEPENDENCIES = host-luajit host-pkgconf libuv libtommath libatomic_ops
MOARVM_CONF_OPTS = \
--build=$(GNU_HOST_NAME) \
@@ -19,6 +19,7 @@ MOARVM_CONF_OPTS = \
--cc="$(TARGET_CC)" \
--ld="$(TARGET_CC)" \
--prefix="/usr" \
+ --pkgconfig=$(PKG_CONFIG_HOST_BINARY) \
--lua=$(HOST_DIR)/usr/bin/luajit \
--has-libuv \
--has-libtommath \