summaryrefslogtreecommitdiff
path: root/package/mono
diff options
context:
space:
mode:
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>2014-11-30 22:41:06 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-11-30 23:51:28 +0100
commit75fa68f5648ed8ccd92c8717794c5499567afeda (patch)
treecc159384a25902e3da3abd22e07b6fed30c5ade2 /package/mono
parent181a17f1b2180eaf2ed9ad5ce783d9f299764427 (diff)
package/mono: fixing wrong monolite library path
Due to a bug in makefile logic, monolite libraries path will not be selected when EXTERNAL_MCS parameter is specified. Setting EXTERNAL_MCS to a non existent binary, makes the internal logic to fallback to monolite, setting correctly both binary and library paths. This has the benefit to force host-mono to always use monolite as bootstrap compiler also in case a mono compiler is already installed on the system. Fixes: http://autobuild.buildroot.net/results/fc00952bef03cf3b4785be1a0d9c08dc84aa3f54/ [Peter: add comment explaining why this is done] Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com> Reported-by: Rainer Berns <rainer.berns@berns-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mono')
-rw-r--r--package/mono/mono.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/mono/mono.mk b/package/mono/mono.mk
index df67c336b..baf205a27 100644
--- a/package/mono/mono.mk
+++ b/package/mono/mono.mk
@@ -55,7 +55,8 @@ HOST_MONO_CONF_OPTS += \
--with-profile4=$(if $(BR2_PACKAGE_MONO_40),yes,no) \
--with-profile4_5=$(if $(BR2_PACKAGE_MONO_45),yes,no)
-HOST_MONO_MAKE_OPTS += EXTERNAL_MCS="$(@D)/mcs/class/lib/monolite/basic.exe"
+# ensure monolite is used
+HOST_MONO_MAKE_OPTS += EXTERNAL_MCS=false
HOST_MONO_DEPENDENCIES = host-monolite host-gettext