summaryrefslogtreecommitdiff
path: root/package/mosquitto
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-04-10 22:33:15 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-04-21 16:08:44 +0200
commitabf4db2c48bf60053cf66b32a0572cd59dd5d624 (patch)
tree7af19b99f928f7a7857ae41c03da12b7f7bb149b /package/mosquitto
parentab6b4c82f4d7857de3b48172e590f8d6dc6c9171 (diff)
package: add mosquitto
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mosquitto')
-rw-r--r--package/mosquitto/Config.in19
-rw-r--r--package/mosquitto/S50mosquitto35
-rw-r--r--package/mosquitto/mosquitto.hash2
-rw-r--r--package/mosquitto/mosquitto.mk90
4 files changed, 146 insertions, 0 deletions
diff --git a/package/mosquitto/Config.in b/package/mosquitto/Config.in
new file mode 100644
index 000000000..8f579f87e
--- /dev/null
+++ b/package/mosquitto/Config.in
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_MOSQUITTO
+ bool "mosquitto"
+ depends on BR2_USE_MMU # fork()
+ depends on BR2_INET_IPV6
+ depends on !BR2_STATIC_LIBS # builds .so
+ help
+ Mosquitto is an open source message broker that implements
+ the MQ Telemetry Transport protocol versions 3.1 and
+ 3.1.1. MQTT provides a lightweight method of carrying out
+ messaging using a publish/subscribe model. This makes it
+ suitable for "machine to machine" messaging such as with low
+ power sensors or mobile devices such as phones, embedded
+ computers or microcontrollers like the Arduino.
+
+ http://mosquitto.org/
+
+comment "mosquitto needs a toolchain w/ IPv6, dynamic library"
+ depends on BR2_USE_MMU
+ depends on !BR2_INET_IPV6 || BR2_STATIC_LIBS
diff --git a/package/mosquitto/S50mosquitto b/package/mosquitto/S50mosquitto
new file mode 100644
index 000000000..9f10cce2e
--- /dev/null
+++ b/package/mosquitto/S50mosquitto
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+start() {
+ echo -n "Starting mosquitto: "
+ start-stop-daemon -S -q -m -b -p /var/run/mosquitto.pid \
+ --exec /usr/sbin/mosquitto \
+ -- -c /etc/mosquitto/mosquitto.conf
+ [ $? = 0 ] && echo "OK" || echo "FAIL"
+}
+stop() {
+ echo -n "Stopping mosquitto: "
+ start-stop-daemon -K -q -p /var/run/mosquitto.pid
+ [ $? = 0 ] && echo "OK" || echo "FAIL"
+}
+restart() {
+ stop
+ start
+}
+
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|reload)
+ restart
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $?
diff --git a/package/mosquitto/mosquitto.hash b/package/mosquitto/mosquitto.hash
new file mode 100644
index 000000000..2f38bdb23
--- /dev/null
+++ b/package/mosquitto/mosquitto.hash
@@ -0,0 +1,2 @@
+# Locally calculated after checking pgp signature
+sha256 75a8b051c7859a2426ffc15bf45b44f79c8288395a325d791ba54e5df9af58a8 mosquitto-1.4.1.tar.gz
diff --git a/package/mosquitto/mosquitto.mk b/package/mosquitto/mosquitto.mk
new file mode 100644
index 000000000..00167503f
--- /dev/null
+++ b/package/mosquitto/mosquitto.mk
@@ -0,0 +1,90 @@
+################################################################################
+#
+# mosquitto
+#
+################################################################################
+
+MOSQUITTO_VERSION = 1.4.1
+MOSQUITTO_SITE = http://mosquitto.org/files/source
+MOSQUITTO_LICENSE = EPLv1.0 or EDLv1.0
+MOSQUITTO_LICENSE_FILES = LICENSE.txt epl-v10 edl-v10
+MOSQUITTO_INSTALL_STAGING = YES
+
+MOSQUITTO_MAKE_OPTS = \
+ UNAME=Linux \
+ STRIP=true \
+ prefix=/usr \
+ WITH_WRAP=no \
+ WITH_DOCS=no
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+MOSQUITTO_MAKE_OPTS += WITH_THREADING=yes
+else
+MOSQUITTO_MAKE_OPTS += WITH_THREADING=no
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MOSQUITTO_DEPENDENCIES += openssl
+MOSQUITTO_MAKE_OPTS += WITH_TLS=yes
+else
+MOSQUITTO_MAKE_OPTS += WITH_TLS=no
+endif
+
+ifeq ($(BR2_PACKAGE_C_ARES),y)
+MOSQUITTO_DEPENDENCIES += c-ares
+MOSQUITTO_MAKE_OPTS += WITH_SRV=yes
+else
+MOSQUITTO_MAKE_OPTS += WITH_SRV=no
+endif
+
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+MOSQUITTO_DEPENDENCIES += util-linux
+MOSQUITTO_MAKE_OPTS += WITH_UUID=yes
+else
+MOSQUITTO_MAKE_OPTS += WITH_UUID=no
+endif
+
+ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
+MOSQUITTO_DEPENDENCIES += libwebsockets
+MOSQUITTO_MAKE_OPTS += WITH_WEBSOCKETS=yes
+else
+MOSQUITTO_MAKE_OPTS += WITH_WEBSOCKETS=no
+endif
+
+# C++ support is only used to create a wrapper library
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+define MOSQUITTO_DISABLE_CPP
+ $(SED) '/-C cpp/d' $(@D)/lib/Makefile
+endef
+
+MOSQUITTO_POST_PATCH_HOOKS += MOSQUITTO_DISABLE_CPP
+endif
+
+define MOSQUITTO_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+ $(MOSQUITTO_MAKE_OPTS)
+endef
+
+define MOSQUITTO_INSTALL_STAGING_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+ $(MOSQUITTO_MAKE_OPTS) DESTDIR=$(STAGING_DIR) install
+endef
+
+define MOSQUITTO_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+ $(MOSQUITTO_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
+ rm -f $(TARGET_DIR)/etc/mosquitto/*.example
+ $(INSTALL) -D -m 0644 $(@D)/mosquitto.conf \
+ $(TARGET_DIR)/etc/mosquitto/mosquitto.conf
+endef
+
+define MOSQUITTO_INSTALL_INIT_SYSV
+ $(INSTALL) -D -m 0755 package/mosquitto/S50mosquitto \
+ $(TARGET_DIR)/etc/init.d/S50mosquitto
+endef
+
+define MOSQUITTO_USERS
+ mosquitto -1 nogroup -1 * - - - Mosquitto user
+endef
+
+$(eval $(generic-package))