summaryrefslogtreecommitdiff
path: root/package/mplayer
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-03-29 19:11:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-08 23:00:34 +0200
commit0ae0eb1cc86e68b987ba2c33aa4f069af1493ec0 (patch)
tree584eb8403e919ed32556021e78bd70318528915a /package/mplayer
parent08cead4e89d48fe0d3d2f68bcc9a1235ff97c73f (diff)
package/mplayer: add optional rtmpdump support
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mplayer')
-rw-r--r--package/mplayer/mplayer.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index 46bc2b078..412837dc7 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -166,6 +166,14 @@ else
MPLAYER_CONF_OPTS += --disable-gif
endif
+# We intentionally don't pass --enable-librtmp to let autodetection
+# find which library to link with.
+ifeq ($(BR2_PACKAGE_RTMPDUMP),y)
+MPLAYER_DEPENDENCIES += rtmpdump
+else
+MPLAYER_CONF_OPTS += --disable-librtmp
+endif
+
ifeq ($(BR2_PACKAGE_LZO),y)
MPLAYER_DEPENDENCIES += lzo
MPLAYER_CONF_OPTS += --enable-liblzo