summaryrefslogtreecommitdiff
path: root/package/mplayer
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-03-29 19:11:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-30 22:57:38 +0200
commit2c7373b370ca0edf54ebc3cc3f7cc67055219f55 (patch)
tree33e5cb95b33069579b4e7ce4d49213557f1b43ba /package/mplayer
parent6fb0b019221383b6bdc3820821c755e6d548709a (diff)
package/mplayer: add optional giflib support
[Thomas: Use --enable-gif / --disable-gif, and do not pass --extra-libs.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mplayer')
-rw-r--r--package/mplayer/mplayer.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index 192a42eeb..70a8842ea 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -100,6 +100,13 @@ else
MPLAYER_CONF_OPTS += --disable-live
endif
+ifeq ($(BR2_PACKAGE_GIFLIB),y)
+MPLAYER_DEPENDENCIES += giflib
+MPLAYER_CONF_OPTS += --enable-gif
+else
+MPLAYER_CONF_OPTS += --disable-gif
+endif
+
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBTHEORA),libtheora)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBPNG),libpng)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)