summaryrefslogtreecommitdiff
path: root/package/mplayer
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-03-29 19:11:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-08 23:01:25 +0200
commit5575b651199994a1adc8a91e681f4ded0eb2d31c (patch)
tree3a07ad3e89b8e8241109aff270f12a68d2d77507 /package/mplayer
parent87a292b62dea4602c4c664ee49629116889cfade (diff)
package/mplayer: add optional libiconv support
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mplayer')
-rw-r--r--package/mplayer/mplayer.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index 5e295515f..2ddc0fc37 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -68,6 +68,14 @@ else
MPLAYER_CONF_OPTS += --disable-fribidi
endif
+# We intentionally don't pass --enable-libiconv, to let the
+# autodetection find which library to link with.
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MPLAYER_DEPENDENCIES += libiconv
+else
+MPLAYER_CONF_OPTS += --disable-iconv
+endif
+
# We intentionally don't pass --enable-termcap, in order to let the
# autodetection find with which library to link with. Otherwise, we
# would have to pass it manually.