summaryrefslogtreecommitdiff
path: root/package/mplayer
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-01-17 22:18:20 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-08 21:19:39 +0100
commit64f2920765bd0771fb8a0956ac11c2d697c70649 (patch)
treee5d457dd49cc31ca2c7898afef870a46135d0476 /package/mplayer
parentc0e5c9c685db9a5c7d869a62443b4abb19ef46d6 (diff)
package/mplayer: add optional dependencies to libgl, libvpx and opus
Mplayer links to these packages when present: output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/mplayer | grep NEEDED | grep "opus\|vpx\|GL" 0x0000000000000001 (NEEDED) Shared library: [libopus.so.0] 0x0000000000000001 (NEEDED) Shared library: [libvpx.so.2] 0x0000000000000001 (NEEDED) Shared library: [libGL.so.1] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mplayer')
-rw-r--r--package/mplayer/mplayer.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/mplayer/mplayer.mk b/package/mplayer/mplayer.mk
index 3051afab1..2082f2519 100644
--- a/package/mplayer/mplayer.mk
+++ b/package/mplayer/mplayer.mk
@@ -231,9 +231,12 @@ MPLAYER_CONF_OPTS += --disable-liblzo
endif
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_BZIP2),bzip2)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_HAS_LIBGL),libgl)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBTHEORA),libtheora)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBPNG),libpng)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBVPX),libvpx)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
+MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_OPUS),opus)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBX11),xlib_libX11)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBXEXT),xlib_libXext)
MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBXINERAMA),xlib_libXinerama)