summaryrefslogtreecommitdiff
path: root/package/mpv
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-04-28 11:33:07 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-04-28 20:35:39 +0200
commit038d82eda4819d78cd68e8b4bf8e8494edcd6eb8 (patch)
tree1f30261805af99e7e1709c2a3d9aedf54066c5a0 /package/mpv
parent6f8851d49cb1a28fb2110a788da8d856e9a8d7b6 (diff)
mpv: va-api requires egl-drm, wayland and/or x11
The VA-API acceleration requires one or more of the egl-drm, wayland and/or x11 backends. Since the egl-drm backend means LIBGL (X11) + EGL + DRM we'll handle it later once the mesa3d libgl hidden knob is applied. So for now we'll support wayland and x11 until that happens. Fixes: http://autobuild.buildroot.net/results/4b9/4b98d0c2c0617715e77fb47b3d97037c6b7562ec/ [Peter: pass --disable-vaapi if libva isn't enabled, invert wayland/X11 test as suggested by Thomas] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mpv')
-rw-r--r--package/mpv/mpv.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/mpv/mpv.mk b/package/mpv/mpv.mk
index 605e8912f..3c6e3922b 100644
--- a/package/mpv/mpv.mk
+++ b/package/mpv/mpv.mk
@@ -177,12 +177,18 @@ MPV_CONF_OPTS += --disable-sdl1 --disable-sdl2
endif
# va-api support
+# This requires one or more of the egl-drm, wayland, x11 backends
+# For now we support wayland and x11
ifeq ($(BR2_PACKAGE_LIBVA),y)
+ifneq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_XLIB_LIBX11),)
MPV_CONF_OPTS += --enable-vaapi
MPV_DEPENDENCIES += libva
else
MPV_CONF_OPTS += --disable-vaapi
endif
+else
+MPV_CONF_OPTS += --disable-vaapi
+endif
# wayland support
ifeq ($(BR2_PACKAGE_WAYLAND),y)