summaryrefslogtreecommitdiff
path: root/package/mtd
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2015-09-11 07:08:37 +0300
committerPeter Korsgaard <peter@korsgaard.com>2015-09-13 22:43:35 +0200
commitbfcf697712e5b636d755751ac0f69afed253f46a (patch)
tree7f7926aaa4a159683087ab57884fe055744b428d /package/mtd
parentcb68e9fccb4b3af08d72645141075b1a785fd5ac (diff)
mtd: fix static build with uuid
The uuid library might depend on gettext. Use pkg-config to discover uuid dependencies at build time, and edit Makefile accordingly to avoid missing symbols when linking statically. Based on a patch from Vicente Olivert Riera. Fixes: http://autobuild.buildroot.net/results/2dd/2ddd714446d9eb75701bd48c117dc5bbbd291a76/ http://autobuild.buildroot.net/results/3af/3af4ef252c8cb2b22134d91ce48e5930c60ec437/ http://autobuild.buildroot.net/results/648/648341fce974e8f016eee57c95d7511a886eef49/ [Peter: drop MTD_MKFSUBIFS_LIBS variable] Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Tested-by: Gergely Imreh <imrehg@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/mtd.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index 0fb9fc2c1..adbf28d8f 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -17,7 +17,12 @@ MTD_DEPENDENCIES = zlib lzo
endif
ifeq ($(BR2_PACKAGE_MTD_MKFSUBIFS),y)
-MTD_DEPENDENCIES += util-linux zlib lzo
+MTD_DEPENDENCIES += util-linux zlib lzo host-pkgconf
+define MTD_ADD_MISSING_LINTL
+ $(SED) "/^LDLIBS_mkfs\.ubifs/ s%$$% `$(PKG_CONFIG_HOST_BINARY) --libs uuid`%" \
+ $(@D)/Makefile
+endef
+MTD_POST_PATCH_HOOKS += MTD_ADD_MISSING_LINTL
endif
ifeq ($(BR2_PACKAGE_BUSYBOX),y)