summaryrefslogtreecommitdiff
path: root/package/musl
diff options
context:
space:
mode:
authorSergio Prado <sergio.prado@e-labworks.com>2015-12-01 22:58:28 -0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-17 22:02:27 +0100
commitfa6473729cf868dff232dfbc9674a168cc3f9b97 (patch)
tree72ad38bb2ba13aa0151f4683aa6983b4408d3731 /package/musl
parent1a886a9a25446c04371f5698ae34d9cb7b12c5fa (diff)
musl: add a sys/queue.h implementation
Musl does not provide a 'sys/queue.h' implementation, and this has been a problem for packages that depend on it. So lets create a package called netbsd-queue that will install a 'sys/queue.h' in the staging directory when enabled, based on the NetBSD implementation. Musl toolchain and external toolchain packages will depend on this package, so that 'sys/queue.h' will be always installed when compiling with a musl based toolchain. Tested on ARM and x86 in the following cases: - Buildroot musl toolchain. - External musl toolchain without 'sys/queue.h'. - External musl toolchain with 'sys/queue.h'. Fixes: http://autobuild.buildroot.net/results/24bad2d06ab40024dacf136bee722072d587f84e And possibly many others. Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/musl')
-rw-r--r--package/musl/musl.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/musl/musl.mk b/package/musl/musl.mk
index 6fdcc7312..2cc6699a3 100644
--- a/package/musl/musl.mk
+++ b/package/musl/musl.mk
@@ -13,6 +13,11 @@ MUSL_LICENSE_FILES = COPYRIGHT
# cross-compiler and the kernel headers
MUSL_DEPENDENCIES = host-gcc-initial linux-headers
+# musl does not provide a sys/queue.h implementation, so add the
+# netbsd-queue package that will install a sys/queue.h file in the
+# staging directory based on the NetBSD implementation.
+MUSL_DEPENDENCIES += netbsd-queue
+
# musl is part of the toolchain so disable the toolchain dependency
MUSL_ADD_TOOLCHAIN_DEPENDENCY = NO