summaryrefslogtreecommitdiff
path: root/package/ncurses
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-05-28 17:12:39 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-06-01 22:50:30 +0200
commit8398016e946f83ef7704c4ca1bc6f690a218a549 (patch)
tree998b3d8aa8e5d6a5082f0b08cea1fddcd9b2f153 /package/ncurses
parent3663bc4ff295b98fbbc1aafb38fdbc46fee7c80e (diff)
ncurses: enable parallel build
Using a trick taken from gentoo enable parallel build when building for the target to reduce the build time for my test case from about 54s to 32s on a dual-core laptop. [Peter: add comment explaining why] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index 980511380..4bba8f1b3 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -45,8 +45,12 @@ ifneq ($(BR2_ENABLE_DEBUG),y)
NCURSES_CONF_OPT += --without-debug
endif
+# ncurses breaks with parallel build, but takes quite a while to
+# build single threaded. Work around it similar to how Gentoo does
define NCURSES_BUILD_CMDS
- $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR)
+ $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR) sources
+ rm -rf $(@D)/misc/pc-files
+ $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR)
endef
ifneq ($(BR2_PREFER_STATIC_LIB),y)