summaryrefslogtreecommitdiff
path: root/package/ncurses
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:33 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:52:32 +0100
commitf8639c79d8f8af4ac01176e64d69062ac4644561 (patch)
tree94b63163f164e91d43dff35f947dc5998d9d2711 /package/ncurses
parent375c77ad4e597bc5c67a151d722b5063322bbb46 (diff)
ncurses: speed up host build by disabling static library building
For the host variant of packages, we normally only build the shared libraries. However, ncurses uses non-standard options to select between shared/static and therefore the host variant was building both of them, even though the static libraries were unused. By passing --without-normal, we disable the build of static libraries. It saves a bit of disk space, and on my laptop, host-ncurses takes 26 seconds to build instead of 40 seconds. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index 1ce381833..645c25c1b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -145,7 +145,8 @@ HOST_NCURSES_CONF_OPTS = \
--without-manpages \
--without-cxx \
--without-cxx-binding \
- --without-ada
+ --without-ada \
+ --without-normal
$(eval $(autotools-package))
$(eval $(host-autotools-package))