summaryrefslogtreecommitdiff
path: root/package/neardal
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-05-22 00:04:32 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-22 00:04:32 +0200
commit1ae0e16afd1eb3e48c9b49de87f8b1a382a95112 (patch)
tree9efb598d3fc220178c28395965665fd03f652de8 /package/neardal
parentdea306c78b5d4c571555c50512e212a725b594b9 (diff)
neardal: properly quote output of pkg-config
Commit 5504039c4e (neardal: fix readline/libedit detection with static linking) added the output of pkg-config to the LIBS shell variable without adding quotes around it, breaking the logic if the output would ever consist of more than 1 word. Now, pkg-config --libs ncurses currently only outputs '-lncurses', so nothing is really broken (for now atleast), but lets add the quotes before it does or the syntax gets copied somewhere else where it does. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/neardal')
-rw-r--r--package/neardal/neardal.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/neardal/neardal.mk b/package/neardal/neardal.mk
index c65a5e616..ddaecbeb1 100644
--- a/package/neardal/neardal.mk
+++ b/package/neardal/neardal.mk
@@ -25,7 +25,7 @@ endif
# forgets to take that into account, causing the detection to fail
# when linking statically
ifeq ($(BR2_STATIC_LIBS),y)
-NEARDAL_CONF_ENV += LIBS=$(shell $(PKG_CONFIG_HOST_BINARY) --libs ncurses)
+NEARDAL_CONF_ENV += LIBS='$(shell $(PKG_CONFIG_HOST_BINARY) --libs ncurses)'
endif
define NEARDAL_INSTALL_NCL