summaryrefslogtreecommitdiff
path: root/package/net-tools
diff options
context:
space:
mode:
authorAndrew Ruder <andrew.ruder@elecsyscorp.com>2014-08-20 16:02:46 -0500
committerPeter Korsgaard <peter@korsgaard.com>2014-09-15 00:43:41 +0200
commit643baa18726111492792ddf20a61c141f9e46e9d (patch)
tree0d300bee4f49da8378a0d91811c92485f0ae4150 /package/net-tools
parentb4b5ac28b609087e2cdac83dea05caf752bbfe07 (diff)
hostname: fix conflicting installs of /bin/hostname
Surprisingly long-standing issue with conflicting /bin/hostname installs. Reported as early as November 2005 by Joseph Dupre. All together at one point or another there are at least 4 possible sources of /bin/hostname: busybox util-linux coreutils net-tools Buildroot depends on the -F flag being available in the default /etc/inittab. Out of the 4 listed projects only net-tools and buildroot for sure support the -F flag. I'm a little unclear on util-linux as it has been removed entirely (in favor of net-tools) for some time. As of coreutils 6.9.90 (2007-12-01), coreutils does not install its /bin/hostname by default. The following commit reenabled its build: d6e58cb coreutils: fixed missing hostname (Sep 2010) This was done to fix a build error in coreutils regarding help2man. A later patch: 30c5105 coreutils: bump to version 8.21 disabled the help2man functionality entirely but left hostname being installed. On a very related note, net-tools now contains an obsolete check to add util-linux as a dependency to force it to build first (so that net-tools ends up with /bin/hostname). This patch fixes both of these issues so that hostname always comes from one of two places: busybox net-tools Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Co-authored-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Andrew Ruder <andrew.ruder@elecsyscorp.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/net-tools')
-rw-r--r--package/net-tools/net-tools.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/package/net-tools/net-tools.mk b/package/net-tools/net-tools.mk
index 35386558c..a2abf5bbd 100644
--- a/package/net-tools/net-tools.mk
+++ b/package/net-tools/net-tools.mk
@@ -17,11 +17,6 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
NET_TOOLS_DEPENDENCIES += busybox
endif
-# Install after util-linux since net-tools hostname is better
-ifeq ($(BR2_PACKAGE_UTIL_LINUX_BINARIES),y)
- NET_TOOLS_DEPENDENCIES += util-linux
-endif
-
define NET_TOOLS_CONFIGURE_CMDS
(cd $(@D); yes "" | ./configure.sh config.in )
endef