summaryrefslogtreecommitdiff
path: root/package/netsnmp
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-02-15 09:18:35 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-15 09:18:35 +0100
commit4b9a294e1c332a489298ca7ce865ea5f06d69c28 (patch)
treec287caeac1e702ada3a631489c919de47a87c888 /package/netsnmp
parenta25df76b39863e5d1a4e927696bf83055e8ce244 (diff)
netsnmp: fix static linking with openssl
Fixes http://autobuild.buildroot.net/results/084/0845bde5d234bd00d23c7a1b7e18746882dcdde4/ Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/netsnmp.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index 6bb6fe251..4830c00e8 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -40,6 +40,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
NETSNMP_DEPENDENCIES += openssl
NETSNMP_CONF_OPT += \
--with-openssl=$(STAGING_DIR)/usr/include/openssl
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ # openssl uses zlib, so we need to explicitly link with it when static
+ NETSNMP_CONF_ENV += LIBS=-lz
+endif
else
NETSNMP_CONF_OPT += --without-openssl
endif