summaryrefslogtreecommitdiff
path: root/package/nginx
diff options
context:
space:
mode:
authorMartin Bark <martin@barkynet.com>2016-05-03 10:36:54 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-05 22:23:34 +0200
commit4dfc2cb5fe0cba3d0b6624976a936f97a9613dd0 (patch)
tree773f235edf2802217176ad912e6e58894dc50b93 /package/nginx
parent851376149380a47cc34d34227f7333a576e3cd72 (diff)
package/nginx: bump version to 1.10.0
The ngx_http_spdy_module has been superseded by the ngx_http_v2_module so BR2_PACKAGE_NGINX_HTTP_SPDY_MODULE has changed to BR2_PACKAGE_NGINX_HTTP_V2_MODULE Signed-off-by: Martin Bark <martin@barkynet.com> [Thomas: rewrap Config.in.legacy help text.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nginx')
-rw-r--r--package/nginx/0001-auto-type-sizeof-rework-autotest-to-be-cross-compila.patch11
-rw-r--r--package/nginx/Config.in4
-rw-r--r--package/nginx/nginx.hash2
-rw-r--r--package/nginx/nginx.mk6
4 files changed, 9 insertions, 14 deletions
diff --git a/package/nginx/0001-auto-type-sizeof-rework-autotest-to-be-cross-compila.patch b/package/nginx/0001-auto-type-sizeof-rework-autotest-to-be-cross-compila.patch
index 496459ea4..829a435ee 100644
--- a/package/nginx/0001-auto-type-sizeof-rework-autotest-to-be-cross-compila.patch
+++ b/package/nginx/0001-auto-type-sizeof-rework-autotest-to-be-cross-compila.patch
@@ -13,6 +13,8 @@ Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Refresh for 1.8.0.
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+[martin@barkynet.com: Updated for 1.10.0]
+Signed-off-by: Martin Bark <martin@barkynet.com>
---
auto/types/sizeof | 42 ++++++++++++++++++++++++++++--------------
1 file changed, 28 insertions(+), 14 deletions(-)
@@ -30,7 +32,7 @@ index a5f66bb..c6f31ec 100644
#include <sys/types.h>
#include <sys/time.h>
-@@ -25,29 +25,43 @@ $NGX_INCLUDE_UNISTD_H
+@@ -25,22 +25,40 @@ $NGX_INCLUDE_UNISTD_H
$NGX_INCLUDE_INTTYPES_H
$NGX_INCLUDE_AUTO_CONFIG_H
@@ -80,13 +82,6 @@ index a5f66bb..c6f31ec 100644
echo " $ngx_size bytes"
fi
--
--rm -rf $NGX_AUTOTEST*
--
--
- case $ngx_size in
- 4)
- ngx_max_value=2147483647
--
1.9.1
diff --git a/package/nginx/Config.in b/package/nginx/Config.in
index be445f4f6..0c39a635d 100644
--- a/package/nginx/Config.in
+++ b/package/nginx/Config.in
@@ -36,8 +36,8 @@ config BR2_PACKAGE_NGINX_HTTP_SSL_MODULE
help
Enable ngx_http_ssl_module
-config BR2_PACKAGE_NGINX_HTTP_SPDY_MODULE
- bool "ngx_http_spdy_module"
+config BR2_PACKAGE_NGINX_HTTP_V2_MODULE
+ bool "ngx_http_v2_module"
select BR2_PACKAGE_ZLIB
help
Enable ngx_http_spdy_module
diff --git a/package/nginx/nginx.hash b/package/nginx/nginx.hash
index fe4d6b2f0..394f4d2c8 100644
--- a/package/nginx/nginx.hash
+++ b/package/nginx/nginx.hash
@@ -1,2 +1,2 @@
# Locally calculated after checking pgp signature
-sha256 8f4b3c630966c044ec72715754334d1fdf741caa1d5795fb4646c27d09f797b7 nginx-1.8.1.tar.gz
+sha256 8ed647c3dd65bc4ced03b0e0f6bf9e633eff6b01bac772bcf97077d58bc2be4d nginx-1.10.0.tar.gz
diff --git a/package/nginx/nginx.mk b/package/nginx/nginx.mk
index f6bae7e0d..25fb9a886 100644
--- a/package/nginx/nginx.mk
+++ b/package/nginx/nginx.mk
@@ -4,7 +4,7 @@
#
################################################################################
-NGINX_VERSION = 1.8.1
+NGINX_VERSION = 1.10.0
NGINX_SITE = http://nginx.org/download
NGINX_LICENSE = BSD-2c
NGINX_LICENSE_FILES = LICENSE
@@ -104,9 +104,9 @@ else
NGINX_CONF_OPTS += --without-http-cache
endif
-ifeq ($(BR2_PACKAGE_NGINX_HTTP_SPDY_MODULE),y)
+ifeq ($(BR2_PACKAGE_NGINX_HTTP_V2_MODULE),y)
NGINX_DEPENDENCIES += zlib
-NGINX_CONF_OPTS += --with-http_spdy_module
+NGINX_CONF_OPTS += --with-http_v2_module
endif
ifeq ($(BR2_PACKAGE_NGINX_HTTP_SSL_MODULE),y)