summaryrefslogtreecommitdiff
path: root/package/nginx
diff options
context:
space:
mode:
authorMartin Bark <martin@barkynet.com>2016-05-03 10:36:57 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-05 22:44:19 +0200
commitbdbb0c8112bffb783a43a9f44dd7637ebaaf7c89 (patch)
tree1b097e82dbdac178a2d49f9cb24843cdd9b8f758 /package/nginx
parent2748bc6b6544347c75837205c8537d2321d4393f (diff)
package/nginx: add debug logging support
Signed-off-by: Martin Bark <martin@barkynet.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nginx')
-rw-r--r--package/nginx/Config.in8
-rw-r--r--package/nginx/nginx.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/package/nginx/Config.in b/package/nginx/Config.in
index ca3e3eb4b..9f3c218da 100644
--- a/package/nginx/Config.in
+++ b/package/nginx/Config.in
@@ -354,6 +354,14 @@ config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE
endif #BR2_PACKAGE_NGINX_STREAM
+config BR2_PACKAGE_NGINX_DEBUG
+ bool "debug logging"
+ help
+ Enable debug logging. The debug level should be set with
+ the error_log directive. For example
+
+ error_log /var/log/nginx/error.log debug;
+
comment "misc. modules"
config BR2_PACKAGE_NGINX_SELECT_MODULE
diff --git a/package/nginx/nginx.mk b/package/nginx/nginx.mk
index 91772b351..c1e8367da 100644
--- a/package/nginx/nginx.mk
+++ b/package/nginx/nginx.mk
@@ -226,6 +226,9 @@ NGINX_CONF_OPTS += \
endif # BR2_PACKAGE_NGINX_STREAM
+# Debug logging
+NGINX_CONF_OPTS += $(if $(BR2_PACKAGE_NGINX_DEBUG),--with-debug)
+
define NGINX_DISABLE_WERROR
$(SED) 's/-Werror//g' -i $(@D)/auto/cc/*
endef