summaryrefslogtreecommitdiff
path: root/package/ntp
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2016-11-14 14:22:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-28 22:45:35 +0100
commit008ab8d590e59b34bb5d0eebd48bd97e1a553dd0 (patch)
tree7ad2726cf2c86939ff8acd1bff04028c88b8267a /package/ntp
parent114f5a9310744c2ce5dcc1d254d443d172b25a42 (diff)
ntp: fix missing optional dependencies
ntpq and ntpdc may depends on libedit and libcap. $ arm-linux-readelf -d ./usr/bin/ntpdc | grep NEEDED 0x00000001 (NEEDED) Shared library: [libcap.so.2] 0x00000001 (NEEDED) Shared library: [libm.so.6] 0x00000001 (NEEDED) Shared library: [libedit.so.0] 0x00000001 (NEEDED) Shared library: [libncursesw.so.6] 0x00000001 (NEEDED) Shared library: [libssl.so.1.0.0] 0x00000001 (NEEDED) Shared library: [libcrypto.so.1.0.0] 0x00000001 (NEEDED) Shared library: [libpthread.so.0] 0x00000001 (NEEDED) Shared library: [libc.so.6] However, build order with these libraries is not defined. In order to keep things simple, we enforce build order even if ntpq/ntpdc are not selected. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> [Thomas: use --without-lineeditlibs.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ntp')
-rw-r--r--package/ntp/ntp.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
index 0b6304b10..7f9e0d678 100644
--- a/package/ntp/ntp.mk
+++ b/package/ntp/ntp.mk
@@ -28,6 +28,20 @@ else
NTP_CONF_OPTS += --without-crypto --disable-openssl-random
endif
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+NTP_CONF_OPTS += --enable-linuxcaps
+NTP_DEPENDENCIES += libcap
+else
+NTP_CONF_OPTS += --disable-linuxcaps
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDIT),y)
+NTP_CONF_OPTS += --with-lineeditlibs=edit
+NTP_DEPENDENCIES += libedit
+else
+NTP_CONF_OPTS += --without-lineeditlibs
+endif
+
ifeq ($(BR2_PACKAGE_NTP_NTPSNMPD),y)
NTP_CONF_OPTS += \
--with-net-snmp-config=$(STAGING_DIR)/usr/bin/net-snmp-config