summaryrefslogtreecommitdiff
path: root/package/opengl
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-04-05 17:21:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-05 19:20:52 +0200
commitcaae18405d90c17c505f4d8f47fef2d984599121 (patch)
tree0c0354dacfabed6a2279796dc6df2c9965824f2e /package/opengl
parent2bb9df30ad8736567dd4f9244e255ddb37171d1d (diff)
package/libopenmax: rename the _HAS and _PROVIDES variables
The basic rule for a package is to have its options named after the package name. There is no reason this should not also be the case for virtual packages. Besides, this will allow us to switch libopenmax to use the soon-to-be-introduced virtual-package infrastructure. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Mike Zick <minimod@morethan.org> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/opengl')
-rw-r--r--package/opengl/libopenmax/Config.in6
-rw-r--r--package/opengl/libopenmax/libopenmax.mk4
2 files changed, 5 insertions, 5 deletions
diff --git a/package/opengl/libopenmax/Config.in b/package/opengl/libopenmax/Config.in
index 105c53e28..d50f2ced1 100644
--- a/package/opengl/libopenmax/Config.in
+++ b/package/opengl/libopenmax/Config.in
@@ -1,6 +1,6 @@
-config BR2_PACKAGE_HAS_OPENMAX
+config BR2_PACKAGE_HAS_LIBOPENMAX
bool
-config BR2_PACKAGE_PROVIDES_OPENMAX
- depends on BR2_PACKAGE_HAS_OPENMAX
+config BR2_PACKAGE_PROVIDES_LIBOPENMAX
+ depends on BR2_PACKAGE_HAS_LIBOPENMAX
string
diff --git a/package/opengl/libopenmax/libopenmax.mk b/package/opengl/libopenmax/libopenmax.mk
index a2bd23d2a..6cdeacd00 100644
--- a/package/opengl/libopenmax/libopenmax.mk
+++ b/package/opengl/libopenmax/libopenmax.mk
@@ -5,9 +5,9 @@
################################################################################
LIBOPENMAX_SOURCE =
-LIBOPENMAX_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_OPENMAX))
+LIBOPENMAX_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_LIBOPENMAX))
-ifeq ($(BR2_PACKAGE_HAS_OPENMAX),y)
+ifeq ($(BR2_PACKAGE_HAS_LIBOPENMAX),y)
ifeq ($(LIBOPENMAX_DEPENDENCIES),)
$(error No libopenmax implementation selected. Configuration error.)
endif