summaryrefslogtreecommitdiff
path: root/package/openipmi
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2015-07-21 13:11:40 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-21 14:54:32 +0200
commit2d84e1cc4aa7c552e310f3d44f7a557bc5fe8f8f (patch)
treed6b775d0e48136c1f398652ccf1d6fe42b449755 /package/openipmi
parent3c59cfaf291f22ec96531ec1595d339c9b4aa9bd (diff)
openipmi: new package
OpenIPMI provides libraries and command line tools for interacting with IPMI enabled devices. [Thomas: fix indentation.] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openipmi')
-rw-r--r--package/openipmi/Config.in16
-rw-r--r--package/openipmi/openipmi.hash2
-rw-r--r--package/openipmi/openipmi.mk36
3 files changed, 54 insertions, 0 deletions
diff --git a/package/openipmi/Config.in b/package/openipmi/Config.in
new file mode 100644
index 000000000..667efa74a
--- /dev/null
+++ b/package/openipmi/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_OPENIPMI
+ bool "openipmi"
+ depends on BR2_USE_MMU # fork()
+ depends on !BR2_STATIC_LIBS # dlopen()
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_POPT
+ select BR2_PACKAGE_NCURSES
+ help
+ IPMI allows remote monitoring and remote management of
+ devices. OpenIPMI provides a library and command line tools
+ to interact with IPMI enabled devices. OpenIPMI also provides
+ an IPMI BMC simulator.
+
+comment "openipmi needs a toolchain w/ dynamic library, threads"
+ depends on BR2_USE_MMU
+ depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/openipmi/openipmi.hash b/package/openipmi/openipmi.hash
new file mode 100644
index 000000000..3a40f6068
--- /dev/null
+++ b/package/openipmi/openipmi.hash
@@ -0,0 +1,2 @@
+# From http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library/
+sha1 54f63ab7fe09f6a4b0b718601fe9c61014aa220b OpenIPMI-2.0.21.tar.gz
diff --git a/package/openipmi/openipmi.mk b/package/openipmi/openipmi.mk
new file mode 100644
index 000000000..b6abf0f23
--- /dev/null
+++ b/package/openipmi/openipmi.mk
@@ -0,0 +1,36 @@
+################################################################################
+#
+# openipmi
+#
+################################################################################
+
+OPENIPMI_VERSION = 2.0.21
+OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library/
+OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
+OPENIPMI_LICENSE = LGPLv2+, GPLv2+, BSD-3c
+OPENIPMI_LICENSE_FILES = COPYING.LIB COPYING COPYING.BSD
+OPENIPMI_DEPENDENCIES = popt ncurses host-pkgconf
+OPENIPMI_CONF_ENV = ac_cv_path_pkgprog="$(PKG_CONFIG_HOST_BINARY)"
+OPENIPMI_CONF_OPTS = \
+ --with-glib=no \
+ --with-glib12=no \
+ --with-tcl=no \
+ --with-perl=no \
+ --with-python=no \
+ --with-swig=no
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+OPENIPMI_DEPENDENCIES += openssl
+OPENIPMI_CONF_OPTS += --with-openssl=yes
+else
+OPENIPMI_CONF_OPTS += --with-openssl=no
+endif
+
+ifeq ($(BR2_PACKAGE_NETSNMP),y)
+OPENIPMI_DEPENDENCIES += netsnmp
+OPENIPMI_CONF_OPTS += --with-ucdsnmp=yes
+else
+OPENIPMI_CONF_OPTS += --with-ucdsnmp=no
+endif
+
+$(eval $(autotools-package))