summaryrefslogtreecommitdiff
path: root/package/openocd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-02 20:32:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-02 20:32:47 +0100
commit2b937ae4a07fe19f690de1c07851da9cdb0294bf (patch)
tree6d643c49f7301259de8197d620bc9f5ef9beaee0 /package/openocd
parent897d07c313104ddb54fcf9c538acb0ca65e1a687 (diff)
openocd: pass --disable-werror to fix build issues
Should fix: http://autobuild.buildroot.org/results/91d/91d2ae34f14f1978e0985e75f803055d51201a93/ and similar build problems. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openocd')
-rw-r--r--package/openocd/openocd.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/openocd/openocd.mk b/package/openocd/openocd.mk
index b0bcb7e13..c67691c55 100644
--- a/package/openocd/openocd.mk
+++ b/package/openocd/openocd.mk
@@ -16,7 +16,8 @@ OPENOCD_CONF_OPTS = \
--disable-doxygen-html \
--with-jim-shared=no \
--disable-shared \
- --enable-dummy
+ --enable-dummy \
+ --disable-werror
# Rely on the Config.in options of each individual adapter selecting
# the dependencies they need.
@@ -93,7 +94,8 @@ HOST_OPENOCD_CONF_OPTS = \
--disable-doxygen-html \
--with-jim-shared=no \
--disable-shared \
- --enable-dummy
+ --enable-dummy \
+ --disable-werror
HOST_OPENOCD_DEPENDENCIES = host-libftdi host-libusb host-libusb-compat