summaryrefslogtreecommitdiff
path: root/package/openpgm
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-04-14 23:05:52 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-14 23:14:44 +0200
commitc50e7439d912cbc0fd48396cf7559cf477216670 (patch)
tree33ec04951c7825d2aa4e12a4cdc2404089cd6344 /package/openpgm
parentbd67fdee7925ed9773d60cfa22932a1f6f9542ba (diff)
openpgm: make its build system python2/python3 friendly
This patch fixes build issue when python3 is enabled, and host python2 interpreter is not available. Fixes: http://autobuild.buildroot.net/results/01f/01f886a073439c0639ed93e596b68bcadf1a5824/ Signed-off-by: Samuel Martin <s.martin49@gmail.com> Cc: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openpgm')
-rw-r--r--package/openpgm/openpgm-0001-version_generator.py-make-it-python3-compliant.patch42
-rw-r--r--package/openpgm/openpgm.mk1
2 files changed, 43 insertions, 0 deletions
diff --git a/package/openpgm/openpgm-0001-version_generator.py-make-it-python3-compliant.patch b/package/openpgm/openpgm-0001-version_generator.py-make-it-python3-compliant.patch
new file mode 100644
index 000000000..97cff29df
--- /dev/null
+++ b/package/openpgm/openpgm-0001-version_generator.py-make-it-python3-compliant.patch
@@ -0,0 +1,42 @@
+From e04f5c20fc1536f8e6d4faf32f2f4657d441f7c8 Mon Sep 17 00:00:00 2001
+From: Samuel Martin <s.martin49@gmail.com>
+Date: Mon, 14 Apr 2014 17:54:37 +0200
+Subject: [PATCH] version_generator.py: make it python3 compliant
+
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+---
+ openpgm/pgm/version_generator.py | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/openpgm/pgm/version_generator.py b/openpgm/pgm/version_generator.py
+index 2265480..c31376f 100755
+--- a/openpgm/pgm/version_generator.py
++++ b/openpgm/pgm/version_generator.py
+@@ -1,5 +1,7 @@
+ #!/usr/bin/python
+
++from __future__ import print_function
++
+ import os
+ import platform
+ import time
+@@ -8,7 +10,7 @@ build_date = time.strftime ("%Y-%m-%d")
+ build_time = time.strftime ("%H:%M:%S")
+ build_rev = filter (str.isdigit, "$Revision: 1369 $")
+
+-print """
++print("""
+ /* vim:ts=8:sts=8:sw=4:noai:noexpandtab
+ *
+ * OpenPGM version.
+@@ -47,6 +49,6 @@ const char* pgm_build_revision = "%s";
+
+
+ /* eof */
+-"""%(build_date, build_time, platform.system(), platform.machine(), build_rev)
++"""%(build_date, build_time, platform.system(), platform.machine(), build_rev))
+
+ # end of file
+--
+1.9.2
+
diff --git a/package/openpgm/openpgm.mk b/package/openpgm/openpgm.mk
index 3ec5c77e2..951effbc2 100644
--- a/package/openpgm/openpgm.mk
+++ b/package/openpgm/openpgm.mk
@@ -12,6 +12,7 @@ OPENPGM_LICENSE_FILES = openpgm/pgm/LICENSE
OPENPGM_INSTALL_STAGING = YES
OPENPGM_AUTORECONF = YES
OPENPGM_SUBDIR = openpgm/pgm/
+OPENPGM_DEPENDENCIES = $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python)
OPENPGM_CONF_ENV = ac_cv_file__proc_cpuinfo=yes ac_cv_file__dev_rtc=no \
ac_cv_file__dev_hpet=no