summaryrefslogtreecommitdiff
path: root/package/openssh
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2015-08-29 09:46:35 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-29 10:43:52 +0200
commit7bc51f85ae35cf6d60e1622a0df5bf03ae494e39 (patch)
treef0d578ed0c50a28de725afed600cbbfc11c65c7f /package/openssh
parentc7bd65e1d4cab32608cae1dc2c9ee5ab2dd8206c (diff)
openssh: fix static compilation
PIE and static doesn't work on Linux. Fixes: http://autobuild.buildroot.net/results/dce/dce0202e039f4636d68532c4aab8738938b76650/ Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openssh')
-rw-r--r--package/openssh/openssh.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index b95914b62..fb5779e38 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -26,6 +26,10 @@ endef
ifeq ($(BR2_arc),y)
OPENSSH_CONF_OPTS += --without-pie
endif
+# PIE and static does not work on Linux
+ifeq ($(BR2_STATIC_LIBS),y)
+OPENSSH_CONF_OPTS += --without-pie
+endif
OPENSSH_DEPENDENCIES = zlib openssl