summaryrefslogtreecommitdiff
path: root/package/openssl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>2015-09-22 11:23:40 -0300
committerPeter Korsgaard <peter@korsgaard.com>2015-09-23 23:27:42 +0200
commit35495daed39933db06dcc62a335fff89836d1853 (patch)
tree8c983a173c9690128335f3ee468806597f5ed43a /package/openssl
parent7a8c03614f195f8acb2a73bca69ff89caec43c02 (diff)
openssl: change sed expression delimiter
Switch from : to # since CFLAGS can include :'s spilled in from BR2_TARGET_OPTIMIZATION, for example: BR2_TARGET_OPTIMIZATION="-Wl,-rpath,/lib:/usr/lib" would cause the sed expression to fail thus breaking the build. Changed all of the SEDs to # for consistency. Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index c1fc42081..cad8d0c3e 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -65,7 +65,7 @@ define HOST_OPENSSL_CONFIGURE_CMDS
shared \
zlib-dynamic \
)
- $(SED) "s:-O[0-9]:$(HOST_CFLAGS):" $(@D)/Makefile
+ $(SED) "s#-O[0-9]#$(HOST_CFLAGS)#" $(@D)/Makefile
endef
define OPENSSL_CONFIGURE_CMDS
@@ -87,15 +87,15 @@ define OPENSSL_CONFIGURE_CMDS
$(if $(BR2_STATIC_LIBS),zlib,zlib-dynamic) \
$(if $(BR2_STATIC_LIBS),no-dso) \
)
- $(SED) "s:-march=[-a-z0-9] ::" -e "s:-mcpu=[-a-z0-9] ::g" $(@D)/Makefile
- $(SED) "s:-O[0-9]:$(OPENSSL_CFLAGS):" $(@D)/Makefile
- $(SED) "s: build_tests::" $(@D)/Makefile
+ $(SED) "s#-march=[-a-z0-9] ##" -e "s#-mcpu=[-a-z0-9] ##g" $(@D)/Makefile
+ $(SED) "s#-O[0-9]#$(OPENSSL_CFLAGS)#" $(@D)/Makefile
+ $(SED) "s# build_tests##" $(@D)/Makefile
endef
# libdl is not available in a static build, and this is not implied by no-dso
ifeq ($(BR2_STATIC_LIBS),y)
define OPENSSL_FIXUP_STATIC_MAKEFILE
- $(SED) 's/-ldl//g' $(@D)/Makefile
+ $(SED) 's#-ldl##g' $(@D)/Makefile
endef
OPENSSL_POST_CONFIGURE_HOOKS += OPENSSL_FIXUP_STATIC_MAKEFILE
endif
@@ -125,9 +125,9 @@ endef
# libdl has no business in a static build
ifeq ($(BR2_STATIC_LIBS),y)
define OPENSSL_FIXUP_STATIC_PKGCONFIG
- $(SED) 's/-ldl//' $(STAGING_DIR)/usr/lib/pkgconfig/libcrypto.pc
- $(SED) 's/-ldl//' $(STAGING_DIR)/usr/lib/pkgconfig/libssl.pc
- $(SED) 's/-ldl//' $(STAGING_DIR)/usr/lib/pkgconfig/openssl.pc
+ $(SED) 's#-ldl##' $(STAGING_DIR)/usr/lib/pkgconfig/libcrypto.pc
+ $(SED) 's#-ldl##' $(STAGING_DIR)/usr/lib/pkgconfig/libssl.pc
+ $(SED) 's#-ldl##' $(STAGING_DIR)/usr/lib/pkgconfig/openssl.pc
endef
OPENSSL_POST_INSTALL_STAGING_HOOKS += OPENSSL_FIXUP_STATIC_PKGCONFIG
endif