summaryrefslogtreecommitdiff
path: root/package/openssl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-07-19 12:16:11 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-19 18:06:19 +0200
commitc130c5d4635e2a4c7338161953152faf8fca07c4 (patch)
tree01f45d48197a2e65cfa528a787163f2479ab3858 /package/openssl
parent14c1641c1a83b7292783a3e0862403afb4d66c84 (diff)
openssl: drop libdl from pc file
Fixes: http://autobuild.buildroot.net/results/2a2/2a274e2dbffd268a391b0e8a15dae5a759b870a1/ [Thomas: move registration of the hook inside the condition.] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 743ca52ca..7e49a6503 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -115,6 +115,14 @@ define OPENSSL_INSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/c_rehash
endef
+# libdl has no business in a static build
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+define OPENSSL_FIXUP_STATIC_PKGCONFIG
+ $(SED) 's/-ldl//' $(STAGING_DIR)/usr/lib/pkgconfig/openssl.pc
+endef
+OPENSSL_POST_INSTALL_STAGING_HOOKS += OPENSSL_FIXUP_STATIC_PKGCONFIG
+endif
+
ifneq ($(BR2_PREFER_STATIC_LIB),y)
# libraries gets installed read only, so strip fails
define OPENSSL_INSTALL_FIXUPS_SHARED