summaryrefslogtreecommitdiff
path: root/package/openssl
diff options
context:
space:
mode:
authorBenoît Thébaudeau <benoit@wsystem.com>2015-06-19 12:54:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-30 16:44:12 +0200
commitc8937ade4bc29fd8a502b8e9cd0b392a7e76fa30 (patch)
treebd6d0913c9ea69855a8a6ccd3b09443c167d381c /package/openssl
parentf3a2c8a724ee97fc941fc01e2401eedd6c37feae (diff)
openssl: support building the binary without MMU
The commit 720893b62510438237b9923d744dd079ddb4f67d "openssl: disable apps for NOMMU" prevented the openssl binary from being built without MMU in order to fix a build failure without fork(). However, openssl is designed to support the lack of fork() with -DHAVE_FORK=0, so allow the openssl binary to be enabled without MMU thanks to this option. Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Config.in3
-rw-r--r--package/openssl/openssl.mk4
2 files changed, 4 insertions, 3 deletions
diff --git a/package/openssl/Config.in b/package/openssl/Config.in
index 07859ca0c..d147c071e 100644
--- a/package/openssl/Config.in
+++ b/package/openssl/Config.in
@@ -13,15 +13,12 @@ if BR2_PACKAGE_OPENSSL
config BR2_PACKAGE_OPENSSL_BIN
bool "openssl binary"
- # uses fork()
- depends on BR2_USE_MMU
depends on !BR2_STATIC_LIBS
help
Install the openssl binary to the target file system. This is a
command line tool for doing various crypthographic stuff.
comment "openssl binary needs a toolchain w/ dynamic library"
- depends on BR2_USE_MMU
depends on BR2_STATIC_LIBS
config BR2_PACKAGE_OPENSSL_ENGINES
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index fd8904d28..34a983075 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -22,6 +22,10 @@ endef
OPENSSL_PRE_CONFIGURE_HOOKS += OPENSSL_DISABLE_APPS
endif
+ifeq ($(BR2_USE_MMU),)
+OPENSSL_CFLAGS += -DHAVE_FORK=0
+endif
+
ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
OPENSSL_CFLAGS += -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS
OPENSSL_DEPENDENCIES += cryptodev-linux